Zotero experienced error when updating your document (Word, Mac)

edited 9 days ago
Report ID: 753071889

Hi, may I get some guidance in regards to the issue I faced when using Zotero in Word? The error message: "Zotero experienced error when updating your document" shows up whenever I tried to insert a citation. The window will show up, and I can choose citation, but after clicking on 'Done', the citation will remain as {citation} in my document.

I also found out that Zotero seems to work fine in my other Word document, may I know what should I do to solve the problem?
  • [JavaScript Error: "The operation couldn't be completed. (OSStatus error -1728.) @[initField:field.m:70]"]
    See Troubleshooting Errors in Word Processor Documents.
  • edited 9 days ago
    Hi dstillman,

    I've tried steps suggested on the Troubleshooting Errors in Word Processor Documents page. I tried copy and paste the content into a new document, section by section, hoping to find out the problematic citation. The error re-appears when I pasted Chapter 5 into the new document, I then assume the culprit is in Chapter 5. I then deleted Chapter 5, but the problem persists, Zotero is again saying it experienced error when uploading the document.

    I've deleted the bibliography as well, and there's no space in the file name. I've tried 'Accepted All Changes" in my track change and turned it off, as failing to insert the citation sometimes erases my track changes. But the error still appears.

    May I know what's the issue?
  • You'll need to follow the last step. As it explains there, "Unless the error still occurs if you completely clear the contents of the document, this final step will by definition identify the problem."

    Note that there could be multiple problems with the document.
Sign In or Register to comment.