PDF save failed

I tried to save a PDF (e.g. the one at https://bitcoin.org/bitcoin.pdf) in Firefox using the zotero extension. When I am viewing the PDF in the browser, the zotero icon at the top of the window changes to indicate PDF, but when I click on it, I get an X and no PDF shows up in Zotero.

Zotero is running. The status in preferences says the extension says "Zotero is currently available". An error is generated, it is at the bottom of error Report ID: 522943476.

Any advice would be appreciated. Thank you.
  • We'd want a debug ID (different from a report ID) from Zotero (not the Connector):
  • Got it, thank you. The debug id is: D1909899042
  • That's from the Connector, not Zotero.
  • Ah, thank you.

    I have now followed the instructions to enable logging in the help menu, restarted Zotero (not the connector), cleared the log, reloaded the webpage with the PDF, clicked on the icon to get the x, then I hit submit log in Zotero. I get a new error upon log submission: "Invalid response from server." This is in Zotero 6.0.8, which I just downloaded anew from your website.
  • So then you likely just have no network connection in Zotero at all. See Connection Error.
  • (You can paste in the error report and we might be able to tell you more, but it's going to be something on the linked page.)
  • Problem solved by setting network.proxy.type to 0 in an attempt to disable proxying. That 0 was a guess, though. My search skills were not able to turn up documentation of all the values of network.proxy.type. Is that the value I should use?

    More broadly, I don't quite get where Zotero is finding bad (or old?) proxy info. I have no proxy settings or firewall (I just checked iptables and there's no rule for output except the default policy of ACCEPT). Nothing in my environment, no /etc/profile.d/proxy.sh, no firewall manager (e.g. ufw) installed, etc. Every other process on my laptop is reaching the net just fine AFAICT, from Firefox to Chromium to curl, etc.

    At any rate, my local proxy issues aren't for you to debug. I think the problem is now solved using your guidance to your docs. I can save a PDF in zotero again! Thank you for your time and support!
  • The relevant documentation for network.proxy.type is linked from that page — as noted there, 0 means "Direct connection, no proxy". This is just the Firefox proxy system under the hood. Would have to look at startup debug output to say more on the proxy detection, but if you're not using a proxy, just setting it to 0 is fine.
  • Ah, that makes sense. Thanks again.
Sign In or Register to comment.