PDF fails to download due to cookie error with campus library proxy

edited 4 days ago
code from submitting the error report: 1191048011
Running Zotero Connector in an up to date Firefox on Windows 10/11

I believe I get this error when I use the Connector's toolbar button to download an article (e.g. from dl.acm.org) and the "Full Text PDF" fails with a red X in the extension notification. I have tried this both with and without my university library's proxy (set correctly in the Connector's preferences and verified to work on other articles). The metadata seems to propagate into Zotero correctly, and some articles in a given proceedings on the same site work while some do not.

Is there something I can do as a user to communicate this permission and make sure Zotero Connector picks up the PDF as well as the metadata? Thank you!
  • edited 5 days ago
    (Generally speaking, don't quote from error reports — just report the problem you're experiencing and provide a Report ID, and we'll excerpt any relevant errors. I've edited the post title to remove the irrelevant error.)

    Can you provide the URL in question and a Debug ID from Zotero (not the Zotero Connector) for a save attempt that fails?
  • Thanks for the quick response and apologies for not reading the instructions correctly!
    Here's an example URL (without university library proxy, which was present during the attempted zotero download): https://dl.acm.org/doi/10.1145/3477132.3483570
    Zotero debug id: D887769612
    It now looks like the error "is not a PDF" is a perhaps duplicate of something I saw here before posting.
  • (2)(+0000010): Downloaded PDF was not a PDF

    (3)(+0000001): Getting contents of C:\Users\[…]\Zotero\storage\tmp-ZUmKJw\B[…].pdf

    (3)(+0000001): <html><head><title>Shibboleth Authentication Request</title></head><body onload="EZproxyCheckBack()">
    If you're running any Firefox extensions that might be interfering with cookies, try disabling them. You can also try in another browser. You're getting a login page from your proxy server, suggesting either that cookies aren't being properly passed from the Zotero Connector to Zotero to download the file through the proxy or that the proxy server is performing some other check that's causing the request to fail (which would be unusual).

    Does this happen across all sites with gated PDFs, or just ACM?
  • edited 5 days ago
    Cookies! I would never have guessed that from where I was when I started this thread. I disabled all of my cookie-related Firefox extensions and the Enhanced Tracking Protection in the browser itself for good measure, and discovered I can replicate this on the PDF page itself:
    URL: https://dl.acm.org/doi/pdf/10.1145/3477132.3483570
    Zotero D1357371431 (scroll to the bottom for the version with everything cookie-related I can think of disabled in Firefox)

    Edit to add: the version in this post has the campus proxy turned off, since I don't think I should need it when I am already on the PDF.
  • What do you mean by "campus proxy turned off"? Is this a web-based proxy that you log into, or are you using some software external to the browser? You shouldn't be turning anything off.

    Also, to be clear, you want to be saving from the article page, not the PDF itself.
  • edited 5 days ago
    With all my cookie-related add-ons disabled but back on the article page:

    I am able to get different debug output contents (still the same "not a PDF" error) when I am logged in via my personal ACM account instead of using the campus proxy to re-write the URL. Where the thing with the Shibboleth line was before is instead a long HTML page (140312 chars it says at the end) that I think corresponds to the source of the article page.

    Is it possible that it is trying to save the article page as a PDF instead of downloading the PDF?

    Edit: Thanks so much for your help! I apologize for being a frustrating debug subject. :)
  • I was able to replicate the debug output on a Springer site in a way that leads me to believe I am still having cookie-related issues. So I am going to call it quits for now and try with a fresh browser and a fresh session at the campus library at some future time. Thanks again for your help.
  • I was able to successfully download PDFs from a clean browser setup with no extensions that affected cookies and use of my university library proxy. I then added back in all my cookie-related extensions and PDF downloads with the proxy continued to work. I'm still not sure precisely what the problem was, but I'm considering this closed. Thanks again for your help - I would not have ever realized it was cookie-related!
Sign In or Register to comment.