Cmd-Option-drag vs. Link to File

  • I had a similar problem with Linked Files and was able to solve it. May be my experience will may help other users.

    I wanted to store the documents in a Drive folder and link it to two different laptops. In addition, I did not want to use ZotFile.

    For that, I was adding Linked Files by pressing Cmd+Option and dropping it from the Drive folder to Zotero. When I tried to open them in the other laptop I got:
    “Problem: The attached file could not be found at the following path...”.
    This was also happening the other way around between laptops.

    SOLUTION: after several attempts and still unwilling to use ZotFile, I tried adding files directly through the "New Item > Link to File" option. AND IT WORKED!

    So instead of the drag&drop way, I added (one by one) with Link to File and now, I can store the documents in Drive and access them from any of the two laptops.

    Now that I re-read the thread, I see that’s what @dstillman told @jhasselbalch in the beginning. May be being more specific about the adding procedure will help others.

    Long life to Zotero!
  • This sounds like a misunderstanding. Using Cmd-Option is identical to using Link to File, but for technical reasons getting it to take effect can be a little finicky. It should work reliably if you drag over Zotero, wait for Zotero to come to the front, and then let go, as opposed to letting go while Zotero isn't the front-most app. Otherwise it's possible to just end up with a stored file (as if you had done a regular drag), and if you're not using Zotero syncing those files wouldn't be available on your other computer.

    But there shouldn't be any mystery here — you can see from the attachment icon whether it's a stored file or a linked file, and you can also use right-click → Show File to view where the file is located.

    An actual linked file added either way will work exactly the same.
  • @dstillman,

    I know what you mean and I can assure I was doing exactly that: waiting for Zotero window to go front and checking that the file created was a Linked one, with the grey icon on top.

    However and as I said, accessing Linked Files from different computers worked only when I added them directly through the "New Item > Link to File" option. With the dragging method, the paths were not recognised from the other computer.

    I can't tell why, but that's how it worked for me.

  • edited March 2, 2022
    I'm telling you — you were almost certainly just unintentionally creating stored files rather than linked files. A linked file is a linked file. It makes no difference how you add it.

    If you think that's not the case, provide a Debug ID for a drag that creates a linked file and doesn't result in the file being accessible elsewhere.
Sign In or Register to comment.