Export Library doesn't work

This discussion was created from comments split from: Export Library does nothing.
  • Hi,
    I have the same problem.
    I tried to re-do all the above step but the error is still present.

    my log id is D60569080.

    Can anyone help me?

  • Please start new threads for new issues — the thread you posted to was a specific problem one user was encountering 3 years ago. I've moved this to a new thread.

    Can you explain exactly what the problem is you're facing?

    If you disable the Better BibTeX extension (and possibly reset your translators from the Advanced → Files and Folders pane of the Zotero preferences), does the problem go away?
  • Thanks dstillman and sorry for the trouble.

    I solved just 5 minutes ago.

    I am a macOS user.

    I had to removed Zotero and ***its configuration files in ~/Library/Application Support/Zotero***

    Then, installing Zotero and the extensions DOI Manager, Better BibTeX, and
    ZotFile one by one, I was able to obtain an installation where Export Library (with auto-update) works perfectly.

    Before today I wasn't able to obtain a working configuration because I never deleted
    ~/Library/Application Support/Zotero.

    Hope this helps anyone!

  • edited December 16, 2021
    No, you didn't need to delete the application or the entire profile, and people absolutely shouldn't do so blindly. (Deleting the application doesn't do anything, and deleting the profile deletes all settings for no reason.)

    There was likely a particular setting — probably from BBT — that was interfering. Not possible to know what now, but deleting the whole profile and wiping out all Zotero settings was certainly overkill.

    In any case, glad it's working for you now. In the future, if you're going to post here anyway, I'd encourage you to let us debug things with you.
  • I agree with you, it was an overkilling action, but disabling/removing extensions or reinstalling the app didn't solve the problem and I needed to have the bib format of my library today.

    If the error raise again in the future, I will post here for sure!

    Thanks again for your work and availability!

  • edited December 18, 2021
    I'm also having the same problem. My debug ID is D1845835669 (after I deleted the translator and style directories manually and restart). I'm also on macOS.
  • I am also having this same problem.
    I am on windows.
    selecting Export Library simply does nothing.
    debug ID 1754828612

    please help
  • @aurochs: You seem to have submitted that in the middle of various other activity. Restart Zotero, let it sync and settle for a couple minutes, and then provide another Debug ID for an export attempt. Also you have to say what the actual problem is you're experiencing — it's not clear what "same problem" means.

    @philipmarkwick: That's a Report ID. Can you provide a Debug ID for an attempt to export?
  • @dstillman I couldn't export the library. Doing so either through right clicking or File menu does nothing. The new debug ID is D1442000393. I think this happens after I upgraded to the latest beta version. I couldn't revert to the release version because I don't have the backup database (I've been on beta for as long as I can remember).
  • OK, thanks, reproduced. I've fixed this for the next beta, which will be out within a few hours.
  • edited December 19, 2021
    sorry about that... followed the instructions better this time.
    Debug. D1387413696

    The error:
    I choose 'File' then select 'Export Library..' click it. Then literally nothing happens. I see no message or error. It just does not work.

    whereas previously I would choose the folder export the document to another file.

    many thanks for your help on this.
  • Fixed in the latest beta, available now. Thanks for reporting.
  • So not BBT related?
  • Just tried it.
    working exactly as expected.

    Thank you so much :)
  • Thanks..it's working
Sign In or Register to comment.