Issues with built-in PDF reader

edited November 27, 2021
I've been using the built-in PDF reader in version 5.0.97-beta.57+07df7d0de and am experiencing some minor issues:

1. How does one set the zoom level to "fit to page"? The "Resize automatically" option doesn't always work. It appears to work on my larger 24 inch (2560x1440) monitor. However, on smaller screens (14 in 1920x1024 laptop screen), it is still zoomed in too much for a US letter size page.

2. When "Resize automatically" does work, I can use the left and right arrow keys to navigate the pages one page at a time. However, if I use PgDn and PgUp, it advances slightly less than one page, making the document slowly slide down the screen as the page isn't fit to the screen anymore. Does anyone else experience the same behavior?

3. I have a PDF (presentation) whose pages are landscape US letter. Is there a way to only show a single page at a time? Currently, I always see one page together with part of the following page.
This could be related to question 1 above.
  • However, if I use PgDn and PgUp, it advances slightly less than one page, making the document slowly slide down the screen as the page isn't fit to the screen anymore.
    Use Left/Right to move a page at a time. "Page Up" and "Page Down" are misnomers — in most programs, Zotero included, they move a screen at a time, not a logical page at a time.
  • Thanks @dstillman. Is the inability to "fit to page" a known issue, or am I doing something wrong?
  • edited November 29, 2021
    The "Resize automatically" option doesn't always work.
    The PDF reader in Zotero's beta version is based on pdf.js, which is also used in Firefox. While the default in Firefox is "Automatic Zoom", the default in Zotero currently seems to be "Zoom to Page Width". On larger screens, this can lead to a zoom level that is too high. I would prefer if Zotero's default zoom could be changed to "Automatic Zoom", which limits the maximal zoom level. (For smaller windows, "Automatic Zoom" seems to be the same as "Zoom to Page Width".)

    You can change the PDF's zoom level in Zotero through the "View" menu or by using a keyboard shortcut. For example, use Ctrl/Cmd+0 for "Automatic Zoom":
    https://github.com/zotero/zotero/issues/1986#issuecomment-877064552
    Is the inability to "fit to page" a known issue, or am I doing something wrong?
    In Firefox, "Page Fit" can be selected through the zoom menu in the PDF viewer, but this option is currently missing in Zotero's View menu. Note that there's no "Page Fit" shortcut nor a "Page Fit" button in Firefox's PDF viewer. The latter is explained here: https://github.com/mozilla/pdf.js/issues/14286.
    Is there a way to only show a single page at a time?
    It seems to me that there're only "continuous" (or "scrolling") modes in the default pdf.js viewer. "Page Fit" might result in a single page being shown, but you can scroll it. In Firefox, you can get a proper single-page view if you enter the presentation mode, Ctrl+Alt+P. The presentation mode seems to be disabled in Zotero, though.
  • I recently migrated to Zotero from Mendeley Desktop and came here looking for more information about "Fit to Page Height". I think this would be a great addition. When using a display with a resolution of 5120 × 2880, "Zoom to Page Width" results in an extremely zoomed-in document.
Sign In or Register to comment.