Extension Zotero sur safari Mac M1

Bonjour,
J'ai installé Zotero sur mon Mac M1, j'ai réussi à l'ajouter sur Word mais par contre je n'arrive pas à trouver l'extension safari. Est-ce une incompatibilité par rapport a la puce M1 de mon Mac? Comment puis-je faire pour régler ce problème ?
  • @dstillman the article says “ this bug is fixed in macOS Monterey and hope to release the Zotero Connector for Safari with the production version of Zotero when Monterey ships in fall 2021”. Will this be a Monterey only thing, or do you mean it is fixed in Safari 15? Because Safari 15 was released yesterday for Big Sur and Catalina.
  • Monterey. It's a system-level bug with app extensions, not a browser bug.
  • Monterey has been out for a while now, so when will the Zotero Connector for Safari 15 be available?
  • j'ai le même problème avec mon Mac (Monterey OS 12.0.1), impossible d'avoir le connector, je ne peux plus utiliser Zotero.
  • @Gwen29: The Zotero Connector remains available with the Zotero beta. See the link above.
  • @dstillman Thank you for your answer. I don't understand why I cannot see the Zotero icon in Safari anymore though ? Previously I was able to click on it in order to add a reference in my Zotero library, I don't see this icon anymore. Where did it go ???
  • edited 3 days ago
    What version of Zotero do you have?

    Do you see the Zotero Connector in the Extensions pane of the Safari preferences? Is it enabled?
  • @dstillman 5.0.97-beta.57+07df7d0de

    I don't see the Connector in the Extensions pane, it was enabled previously but I don't know how I can enable it again.
  • edited 3 days ago
    What's the full macOS version? Oh, you said Monterey.
  • edited 3 days ago
    @Gwen29: From the support page I linked to above:
    Due to an Apple bug, there's currently an issue where you may need to delete the Zotero beta app from Applications and redownload it after an app update to restore the Zotero Connector functionality in Safari. It may also be necessary to restart your computer in between deleting the app and redownloading.
    We were hoping this was fixed in Monterey, and we haven't reproduced this problem there, but it sounds like this happened to you. First try just restarting your computer and see if that helps. If not, delete the Zotero app and reinstall it from the Zotero beta page.
  • @dstillman OS Monterey 12.0.1
  • @dstillman OK I will do that and keep you informed :-) Thank you
  • Is there a specific way to delete Zotero (I can't find the "uninstall" command)
  • Same as any Mac app. Just delete it from Applications.
  • I also couldn't see the Zotero icon under Safari 15 (MBP M1 Pro/Monterey 12.0.1) even though the extension was supposedly installed. Uninstalling the Zotero beta completely** and reinstalling worked for me.

    **A possibly relevant issue here is that Zotero leaves a ton of caches and other support files behind in various subdirectories of one's Library directory if you only delete it from Applications. A complete uninstall that also removes the service files requires an app like Nektony's App Cleaner and Uninstaller. This could conceivably make a difference re the Zotero icon.
  • @cmenzel: No, it has nothing to do with cache files. It’s just the same macOS bug there’s been all along, described on the support page and above. Deleting the app from Applications and redownloading fixes it. We were hoping this was fixed in Monterey, but seemingly it wasn’t.
  • Fair enough — as noted, a "possibly relevant" issue. :-) At least there's a kludgy but effective workaround!
Sign In or Register to comment.