Wrong font in the Bibliography using Word

Good morning,

for some reason (and for an unknown time), Zotero now insists in using Times New Roman as a font in the bibliography and I cannot change that.

I have found these instructions
but while the word style sheet allows me to change for example the colour or size of the text, the font always appears as TNR.

I'm rather sure that this wasn't a problem "some time ago", but according to our admin there was an update recently? Our Zotero version is and I'm using Word 2019 that was installed on some server version of windows 10. The bug also occurs when starting a new document or using another user account.

Thanks in advance,
  • Zotero doesn't have any font specified anywhere, so this is definitely due to some setting in Word, and none of the relevant code has been updated recently.

    But you can definitely change Word stylesheets to use different fonts. If you're not seeing that option, you're not looking in the right place.
  • Thank you for your response,

    it's very well possible that the bug is not Zotero-centered but occures in the interaction of both programs. But since Timees New Roman is not used anywhere in my document, I qrise the question why part automatically generated by Zotero suddenly is.

    >>But you can definitely change Word stylesheets to use different fonts. If you're not seeing that option, you're not looking in the right place<<

    Yes, I know how to use a word style sheet. I tried to adjust the font and at least the style sheet settings are fine - I mentioned that I was able to change color and text size of the bibliography using that option, right? Yet the font does not change even with correct font settings.
  • edited August 23, 2021
    So you're saying that you're adjusting the font for the "bibliography" style in Word but that doesn't change the font? Can you try switching citation styles and back after doing that?

    (And it's not a question where a bug is; what I'm saying is that there is just no font setting in Zotero that could be adjusted. TNR is specified *somewhere* in Word).
  • Okay, that helped... but in a weird way that I don't understand.

    1.) If I change the citation style, the wrong font remains.

    2.) I then change the font in the word style sheet to some random font and nothing happens, even after refreshing.

    3.) Manually applying the style sheet (with the random font selected) on a reference changes that single reference - and after refreshing, all references have that random font.

    4.) Changing the font in the style sheet now works. The font also stays when changing the citation style back to what I wanted to use.

    5.) To again change the font, I need to go back to point 3.

    Anyhow, thank you for guiding me to this weird workaround :D
  • ...nevermind, that's not a general solution. It works on some documents but not on others. But since Zotero easily takes a minute or two to reformat some hundreds of references, I was able to see the Times New Roman magically (and temporary) appearing in the Word Style Sheet as a standard font during the process once.

  • Is TNR still in the default style? Might be inheriting from there?
  • No, TNR only appeared during the process as a visible setting once. I was only able to see that because some lag or delay allowed me to have both windows open at once (Zotero was stilll updating some references). Usually you have to close the style sheet window before klicking any other options, including the Zotero refresh option.

    I have no programming knowledge, but it looks like Word automatically changes the setting back to TNR if the editing process takes too long... at least the procedure described above works reproducibly well on smaller text files with 3 references but fails in a larger manuscript (about 80 references or so).
  • I think I found what causes the process to break: if I add notes to a reference (via the >Add/Edit Bibliography< function), TNR is selected as font. I can still change the colour and make the whole reference list bold or italic using the Word style sheet but cannot adjust the TNR anymore.
  • To shed some light on what happens when Zotero inserts the bibliography, it is actually using a procedure equal to using Insert -> Text -> Text from File (https://imgur.com/zduZDym) and inserting a RTF file. There isn't really a better way to insert formatted text into Word. The RTF Zotero inserts does not contain font information and Word seems to default that to Times New Roman based on the original defaults of Word. The Zotero plugin then manually resets the paragraph styling of bibliography to the "Bibliography" style in Word and tries to restore the previous font setting of the location, where the text was inserted.

    1. Can you provide a clear way how to reproduce this issue in a new document?
    2. You might be able to fix this by selecting your whole bibliography and manually changing the text font to Calibri, or whatever other font you want to use from the "Home" tab, then applying the "Bibliography" style from the "Styles" subtab/sidebar.
  • 1. Create a new document. Do not change any Word style sheets. Add some lorem ipsum, some references and a reference list. Select a reference and edit the bibliography to add some word to the reference text. Now change the Word style sheet to another font that is not TNR and apply. Nothing will happen, so klick in one line of your reference list and manually apply the literature style sheet. Now either the whole reference or at least one word will have the new font. Refresh your reference list. Your references are now in TNR.

    2. I can manually select the reference list and apply a font from the Home tab but it will ofc be replaced once the reference list gets refreshed. Applying the bibliography style from the style will apply the font for the moment, but it also will be replaced once the list is refreshed.

    What somehow worries me is, that when you take a blank word file (all Calibri, no extra settings), insert some reference and a bibliography and *then* modify the literature style sheet to another font, Zotero already doesn't apply the changes. Even when manually refreshing the reference list, nothing happens until you manually apply the style sheet to one of the references and then again refresh the whole bibliography. From this point on you can use and apply the style sheet as in any other text - but it looks to me as one needed to somehow "connect" the automatically generated bibliography to the style sheet.
    This is only a minor inconvenience, but might hint at a larger problem.

    I've now tested that using a Destkop PC instead of our server system.

  • What version of Word are you running on the Desktop PC? Does this only happen if you edit the bibliography manually? Do you just pick any reference in the bibliography and append some text or do you do something more?

    Did you find any way to get the font to stick after it all going to TNR?
  • I'm using Wors 2019, Version 1808

    I just select any of the references and add a single word to the reference text.
    I just found that I can repair the whole thing by resetting the modified reference. Unfortunately, the edit option is quite valuable to us and the bug is very annoying:

    In our field, we quite often add some extra information to the references, such as "for a recent review see: ..." or just replace a placeholder references with plain comments/formulas/definitions that otherwise would be a footnote/endnote but can only be sorted into the Zotero reference list this way. Also some reference data are unneccessarily complicated and cannot automatically be handled by Zotero as far as we know - but this is leading too far. It's just an important feature to us.
  • Thanks for the additional info, I'll do some further testing, but I haven't managed to reproduce it so far.

    You don't need to make the case for the feature. It's already there because we know it's valuable and it should work properly. It is quite niche so I'm sorry if we cannot address it immediately. At the very least you can always set the correct font on the bibliography before submitting the paper.
  • Great, I really hope you can adress this bug at some point.

    A suitable workaround is, of course, to just copy the bibliography, paste it as regular text and delete the real bibliography.
  • Got the same annoying thing. Whenever a new ref is cited, the font changes to Times New Roman.
  • I seem to be having the same issue as well, but I've only noticed it since the latest beta update (to 5.0.97-beta.50+5f61ac23a). For me, it doesn't appear necessary to insert a new citation for the bibliography to change fonts. Simply refreshing the document pushes the bibliography into Times New Roman for me.

    That said, if I toggle to showing Field Codes on the Times New Roman bibliography, then the proper font from the Bibliography style displays. It's only when the bibliography displays that Times New Roman seems "stuck" as the bibliography font, irrespective of what I do with the style.

    I'm not sure if this helps at all but wanted to mention it. Thanks so much!
  • As an update to this, I am able to get a bibliography in the proper font in a new document and in some other existing documents. The bibliography style is the same across all of them (I've even deleted and merged it back into the document that was misbehaving from one that was working just to be sure).

    But in the document that's giving the bibliography in Times New Roman, I can't for the life of me figure out where Times New Roman is still specified in Word. And it seems especially odd that the bibliography field codes display in the proper font (Arial), but the bibliography itself displays in Times New Roman.

    Is there any sense perhaps to moving the instruction for Zotero to (re)apply the bibliography style to the very end of the process (if it's not already there)?
  • Could @SimonSchwarzwald, @souvenir, or @dstark send a small snippet document where you can reproduce this problem to support@zotero.org with a link to this thread. Make sure you include your full Word version number too.
  • Got that sent in yesterday afternoon, @adomasven. Thanks so much for inviting the samples!
  • I have the same problem, Office 365/Windows 10, and of course Office 365 is a constantly updating subscription so who knows the "actual" Word version...
  • Hi, have there been any updates to fix this issue of different fonts appearing in references, or is the manual workaround of copying and pasting the bibliography as regular text still the go-to solution? Thanks!
  • Hi, I also have the same issue on Zotero 6.0.26, Windows 11, Word 2016.
    The bibliography should adhere to the MDPI style (Palatino Linotype 9), but it keeps changing to Times New Roman 12 whenever I add a new reference/citation.
  • @MuhammadAllam Have you actually edited the style in Word? That's what's controlling the font, not Zotero. On the latest Word on Mac, this is done by going to the Home tab, clicking the Styles Pane, and scrolling down to find "Bibliography", clicking on the arrow on its right to "Modify Style".
  • @enozkan Thanks for the reply. I tried that but with every refresh of zotero bibliography in the document, it goes back to TNR12. I think I played with the styles before and don't remember exactly what I did. I also applied a word template provided by the journal but then I have the zotero.dotm applied as well.. Anyway, I will revert to manual for this one. Thanks.
  • I recreated the problem (maybe someone else referenced this here and I missed it). It appears to only happen for me if I add citations to the bibliography that are not directly referenced in the document. So, in my instance, I had 136 sources which were noted in endnotes. Zotero used the 136 to create a bibliography. When I used the toolbar Zotero feature within Word to add two additional sources that were noted in the text of the document but not in a Zotero-linked note, upon refresh, the now-138 references appeared as Times New Roman. Thus, to return to the font style of choice, I need to select all the bibliography entries, clear the formatting back to Normal, and then reapply my bibliography style. Even so, each time I refresh the bibliography, the problem presents itself again.
  • Can you reproduce this in a new document? Does it matter which items you add in the Edit Bibliography dialog?
Sign In or Register to comment.