Can't Use Zotero in Google Docs

Report ID (Chrome addon): 784578486
Report ID (Zotero on Desktop): 106669715


I was hoping you could help me troubleshoot this problem since I haven't seen it mentioned before on the forums.

I can't add citations to any document on Google Docs. First, I'm being prompted to select the citation style, then the paper to cite, and then get an error saying "Zotero experienced an error updating your document."

The problem might be in the document preferences and not in citing, since, if I go to Zotero->Document preferences (without citing any one paper) and choose the citation style, I get the same error.

Zotero works on Word documents for me. I have re-installed Zotero on my Windows PC and re-installed the Zotero add-on on Chrome, but to no avail. Any ideas on how I could fix this?

  • Seems like Google Docs is returning a very generic error "Action not allowed". It likely has something to do with document permissions and may be a bug in Google Docs. Try to make a copy of the document in Google Docs and try again. If that doesn't work, do you get an error trying to cite in a new doc?
  • Hello!

    Thank you so much for your time.

    You are totally right. My Google Docs account is not the same as my Zotero email.

    I used my main google docs account to share the document with the email address I use for Zotero, and now everything works.

    Thanks again!
  • Note that there's no connection between the two accounts, so there was no need to share the document. You simply have to choose the Google account that you used to create the document when the plugin asks for permission. (A Zotero account isn't even required to use Zotero, so your Zotero account is totally irrelevant.)
  • Oh, I see now! I tried it, and you are totally right. Now I understand better how the system works.

    Thank you :)
Sign In or Register to comment.