Zotero LibreOffice integration issue

I compiled my document in Scrivener and ran the ODT scan in Zotero to get the citations in place. When I open the file in LibreOffice to select the appropriate style, I can see the citations at the bottom of the page. However, when I select a style (Cite them right 10th ed - Harvard), the citation changes to:

When I click on the wheel-Z icon in LibreOffice to change to another style, then I get this message:
The version of the Zotero LibreOffice Integration component installed within LibreOffice, OpenOffice.org, or NeoOffice does not appear to match the version installed in Zotero. Please ensure both components are up to date and try again.

When I clicked on the wheel-Z icon in LibreOffice again to attempt to change the style, I do not get the pop-up window with the styles, but instead, Zotero comes forward from the open screens. The only option here is to shut LibreOffice

I closed without saving and repeated the process, trying a different style but got the same result. This time, I got this message:
Zotero experienced an error updating your document.
Would you like to view troubleshooting instructions?
I had already gone through this process to no avail.
  • Could you submit a Report ID from Zotero?
  • ID: 663080084
  • Does it help if you go into Zotero Preferences -> Cite -> Word Processors and reinstall the LibreOffice plugin?
  • Just reinstalled. I change the style to Cite them right and then Bluebook to check. Report ID: 429044938
  • [JavaScript Error: "TypeError: dois[0] is undefined" {file: "chrome://zotero-scite/content/Scite.js" line: 74}]
    You're getting errors from the Scite plugin. Start by disabling that.
  • Done. Report ID: 97196286
  • edited June 22, 2021
    There are no errors in there. Are you saying you reproduced the problem before generating that?

    If so, can you provide a Debug ID (different from a Report ID) for reproducing the error?
  • I created the report after the problem happened but Aotero was already opened.

  • edited June 22, 2021
    What’s the actual problem that you’re currently experiencing? What steps is this debug output meant to show? You appear to have submitted this as soon as Zotero started, without actually triggering anything related to word processor integration.
  • When switching to another citation style i.e. Bluebook, the citations from the ODF scan turn into:

    This time, it took a long time, but the citations appeared after. I tried another style just to check, and then it hanged. I tried clicking the wheel to change styles and the Zotero window came to the front instead of having the menu showing the styles come up.

    I ran it again and waited before I redid the Debug ID. Here it is: D1367370261
  • (3)(+0000002): Integration: updateDocument complete in 79.409s

    (3)(+0000001): LibreOfficePlugin: Sending 5314 ["Document_setDocumentData",[6,"<data data-version=\"3\" zotero-version=\"5.0.97-beta.29+2fd46157f\"><session id=\"SOmirj4U\"/><style id=\"http://www.zotero.org/styles/oscola\"; hasBibliography=\"1\" bibliographyStyleHasBeenSet=\"0\"/><prefs><pref name=\"fieldType\" value=\"ReferenceMark\"/><pref name=\"noteType\" value=\"1\"/><pref name=\"dontAskDelayCitationUpdates\" value=\"true\"/></prefs></data>"]]

    (3)(+0000002): LibreOfficePlugin: Read 5314 null

    (3)(+0000000): Integration: OpenOffice-setDocPrefs complete in 91.222s

    (3)(+0000000): LibreOfficePlugin: Sending 5315 ["Document_activate",[6]]

    (3)(+0000004): LibreOfficePlugin: Read 5315 null

    (3)(+0000001): LibreOfficePlugin: Sending 5316 ["Document_complete",[6]]

    (3)(+0000001): LibreOfficePlugin: Read 5316 null
    That shows it completing — seemingly successfully — in about a minute and a half. Are you saying something went wrong there?
  • Ok. Based on what you suggested, it appeared that reinstalling the plug-in with LibreOffice was the fix. I am unsure how did it go from installed to uninstalled. How often do I have to reinstall it?

    I just enabled the scite_ plug-in to check if, with the LibreOffice reinstall, the problem that is causing it to hang is this plug-in.


  • It was not uninstalled, you just had an old (possibly very old) version of it in LibreOffice. Normally Zotero will update it in LibreOffice automatically when changes are released, but sometimes that fails. You won't need to do this manually anytime soon now that you've reinstalled it from Zotero.
  • OK, I will keep an eye out for it when Zotero updates. Thanks!
  • I thought you should know.

    I received a pop-up from Zotero about a beta update, which I executed. After restarting Zotero, I checked the word processors plug-ins, and both show not installed.

    Is there anything I can do to avoid having to reinstall the plug-in after every update?
  • Have you restarted Zotero since reinstalling the plugin? Did you do it properly by closing the program (instead of closing with task manager or similar)? If so, if you reinstall the plugin now and restart Zotero, does the installed preference stick?
  • When the pop-up appeared asking if I wanted to update Zotero, the only way to say yes was to click on the "restart now" button. After I did that, I checked on the plug-in, and it needed to be reinstalled, so I did.

    After receiving your message, I shut down Zotero, and a pop-up appeared asking me to wait until updates were installed. When it was done, I went back to check on the plug-in, and sure enough, it needed to be reinstalled again.

    Something is definitely wrong.
  • I might have a different cause for the issue, but I have had the "x add-in is not currently installed." after update issue for many years. It never gets in the way of the add-in actually working within Word, since there is a Zotero.dotm file in the StartUp folder and the addin works beautifully within Word. Of course, it may be an older version of the addin file there.

    Manually instigating the install in the Cite window of the preferences makes the "not currently installed" go away and updates the timestamp on the Word folder, so that's all good (I just checked Office's Startup Folder Zotero.dotm before and after manual reinstall from Preferences.) The file has the same exact size and last edit date (from April 13) as before, so it is likely that the add-in hasn't changed since then, but Zotero still thought the add-in was not installed. So, I guess Zotero failed to automatically write Zotero.dotm to that folder, registered that failure, and therefore reported that it was not installed. I am guessing.

    I seem to have proper read/write privileges drwxr-xr-x for the folder and -rw-r--r--@ for Zotero.dotm. There is an extended attribute on the dotm file, com.apple.FinderInfo 32, but I don't know what that does.

    Working with latest beta (5.0.97-beta.32+3fc7ce8e7) on Mac OS 10.14.6 (up to date) and in Word for Mac 16.50 through a Microfost 365 subscription). Same thing happens with LibreOffice and on multiple Mac machines.
  • @enozkan I have the same version on Zotero, MacOS 11.3.1, and LibreOffice, but I am certainly not technically savvy to check what you are suggesting.

    @adomasven What do you think?
  • @army-jag341 I checked the code and it seems like there's a bug in the check for whether the plugin is installed. We'll fix that for the next update. Once again, you shouldn't need to worry about this in the near term and Zotero will update the LibreOffice plugin automatically going forward.
  • Thank you so much for checking. Is there anything else you would need from me?
  • Nope. Thanks for reporting this!
  • @adomasven I am unsure what happened, but I am experiencing a similar issue. When I open the doc in LibreOffice after the ODF scan, I see citations populating with no problem, but of course, they are not the right style. The issue is that when I try to change the citation style, all codes resort to [citation], and the message about some citations not being in the library pops up.

    I checked that I had the add-on that we had the issue with the last time disabled. I updated LibreOffice to the last version. Here is the Report Error I got in case you need it: 53805230

    Thank you so much, and sorry for the trouble.
  • Multiple issues here, one of them being that an Alert that Zotero is trying to display in LibreOffice is not working. Could you produce a Debug ID from Zotero for the action that causes the error?
  • Thank you so much for getting back to me. Here it is: D432280799

    As I am sending this, the spinning wheel is going on LibreOffice, and I do not have any other option but to force quit it. The same happened yesterday with Zotero
  • The document contains nearly 1000 citations. There's nothing obvious in the debug log you sent us that went wrong and I cannot chalk this off to anything else other than Java or LibreOffice instability. Your best bet is to split this document up into multiple pieces and try to refresh them separately. Also see Troubleshooting Errors in Word Processor Documents.
  • OK. Let me give that a try. I went through the document to double-check the fields where the citations were "missing," and I corrected the different one.

    Is there anything in the log that would explain having to force quit Zotero?
  • At this point I am not sure what the problem is. Do you have to force quit Zotero, LibreOffice, or both? The log doesn't have anything to explain any freezing. Zotero issues a command to LibreOffice (which at that point is over 3000th command in the transaction) and never receives a response.
  • In separate instances, I had to force quit one or the other or both. I would get the usual pop-up window asking if I wanted to report it, but I did notice that it mentions that the program hanging around the top of the report; it mentioned that the program hanged. I would keep an eye on it and see what I am doing when it hangs. Would that work?
  • Any information might help, but do note that at the sizes of the document you are working on we may have limited ability to help or fix it. If you're seeing LibreOffice crash randomly, there's very little we can do or debug, we can only suggest workarounds, like splitting the doc up.
Sign In or Register to comment.