Problems with Quick Copy export

I'm having the following problem with Zotero standalone's Quick Copy export:

When I hit Cmd-Shift-C, or try to drag a citation into another program's text box, nothing happens (Cmd-V pastes whatever happened to be in the paste buffer before, and the dragged cite just disappears). However, on the Edit menu, "Copy as Scannable Cite" shows up, and if I select it the feature works properly. The Cmd-Shift-C shortcut, shown next to it, does not work, only selection from the menu.

Any ideas?

Zotero 5.0.96.2
Mac OS 10.15.7

Thanks, David
  • edited 16 days ago
    Managed to fix this, but will leave the fix here in case anyone else has this problem

    Changing the shortcut for Copy as Scannable Cite using Keyboard / Shortcuts/ App Shortcuts in System Preferences had the effect of making *both* the new shortcut that replaced Cmd-Shift-C and dragging-and-dropping work. Weird!
  • If this happens again, you could try the following:

    Check your export settings:
    https://www.zotero.org/support/preferences/export

    Change your shortcut, e.g., to Cmd-Shift-H:
    https://www.zotero.org/support/preferences/advanced#shortcuts

    Even without any changes, check if restarting Zotero helps.

    (I'm not using the Quick Copy function frequently. In my limited usage on a Windows 10 setup, though, it seemed like the standard Quick Copy shortcut might stop working from time to time. But I'm not sure about this.)
  • @dwoodruff: It's extremely unlikely that that was the fix. Changing the shortcut key via the system shouldn't have any effect whatsoever on drag-and-drop. I'd guess that you did something else (e.g., restarting Zotero).
  • @dwoodruff: And you can almost certainly remove that customization and restart Zotero and it will continue to work.
Sign In or Register to comment.