Bug - Random persistent Zotero tooltip on Windows

For a few days I've been randomly getting persistent tooltips from items in Zotero. This has been happening on two different Windows 10 PCs, both with Zotero beta installed.

I've taken a few screenshots (since it's happening now, I have a persistent tooltip as I'm writing this post):


These tooltips persist both inside Zotero (screenshot 1 and 2) and on everywhere else on the PC (screenshot 3, just an example of the tooltip while in Brave, but it's stuck if I go to any other app/window/tab, including the desktop).

They happen randomly (they don't happen every time Zotero renders a tooltip) and disappear equally as randomly - sometimes they vanish on their own, but most of the times I must restart Zotero for it to go away. I have not been able to identify what triggers it.

If I hover my mouse over the persistent tooltip, it disappears for a second only to appear on a slightly different location (see screenshot 1 to screenshot 2).

Showing other tooltips in Zotero doesn't change anything regarding the tooltip that's persistent (screenshot 4).


PS: just now, opening and closing the "About Zotero" dialog to copy the version number made the persistent tooltip disappear on closing
  • I've been experiencing the same issue. One desktop PC and one Laptop, both fully updated Win10 x64 (latest 20H2 updates).

    Zotero 5.0.97-beta.24+833ee1051

    Really annoying, and I also haven't found anyway to make it go away except by moving the mouse/hovering over it, but it just reappears whenever the mouse cursor stops.
  • This happened again this morning, and I tried to make it go away by opening and closing the "About Zotero" dialog and it did nothing, the tooltip is still there as we speak, and it appeared about 7h ago. So I guess the "About Zotero" thing was just a coincidence
  • Does it go away if you hover over a PDF tab in order to get a tooltip there?
  • I am seeing this exact issue on Ubuntu with Zotero 5.0.97-beta.25+146e1af18. Opening and PDF tab and hovering on the tab fixes the issue temporarily, thanks @dstillman! When I close the PDF tab, the issue comes back.
  • @dstillman: I'm also seeing this. I tried to look into the issue by running a line from the tooltip code in the Run JavaScript window in different situations:
    var tooltipElem = document.getElementById('fake-tooltip');

    The problem seems to be that the tooltip remains in a {"state": "open"} situation after the PDF tab has been closed. This can happen when closing a PDF tab with the mouse pointer. While hovering over the close "x" button, you're getting the tooltip. Once the tab is closed, it somehow can't go to the {"state": "closed"} situation, which seems to be causing the issue.
  • edited May 17, 2021
    @qqbb: Thanks for investigating. We'll fix.
  • @dstillman I had a tooltip appearing earlier today (in the weekend it didn't show up) and I tried what you suggested (hover over a PDF tab) and I came to report that my experience was the same as @cheflo

    But I see that @qqbb seems to have figured out what seems to be the cause :)
  • This is fixed in the latest beta.
Sign In or Register to comment.