Zotero not working in Google Docs

edited 12 days ago
I'm trying to add citations to a google doc. I have the zotero desktop app opened and zotero connect installed (have already tried removing and re-adding to chrome several times). Anytime I try to add a citation I get a message saying
"Zotero experienced an error updating your document.

Would you like to view troubleshooting instructions?"

It isn't a particular broken citation as this happens in any new or existing google doc I open. Chrome is updated, have tried removing and re-adding zotero connect to chrome, restarting chrome, etc.

Anyone know how else to troubleshoot this?
  • It looks like something just changed a few minutes ago in Google Docs that's breaking Zotero integration. We'll investigate. Sorry for the trouble.
  • edited 12 days ago
    No need for further reports — I've deleted a few to keep this thread clear. This is broken for everyone, due to a site change on Google Docs. We'll report back as soon as we have more information.
  • A fix for this is now available in Zotero Connector 5.0.85 for Firefox.

    We've submitted 5.0.85 to the Chrome and Edge extension stores, though it may be a couple days before the new version is accepted. You can work around this by using Firefox in the meantime.

    We'll also push an updated Safari extension in a Zotero beta today.
  • The updated Edge extension is now available.
  • edited 11 days ago
    The updated Chrome extension is now available. You should receive it automatically within a few hours, or you can update right away from the Extensions pane in Chrome. Be sure to reload Google Docs after updating.

    A new Zotero beta with an updated Safari extension is now available as well.

    Sorry again for the inconvenience.
  • Ah thank you so much, the updated Chrome extension is working great!
  • Can you post a link please to the Chrome extension update please
  • @phadjipieris: You should have the update automatically by now, but if not, you can update from the Extensions pane in Chrome, as I say. You can also always reinstall the extension from the download page.
  • Thank you for the fix and the fantastic communication about this issue. The 5.0.85 version works great.
  • edited 10 days ago
    Closing this thread, since the original issue is fixed in Zotero Connector 5.0.85.

    If you're still having trouble, please start a new thread and provide a Report ID from Zotero and a description of exactly what's happening.
This discussion has been closed.