Google Scholar "import into Endnote" issue with enw files.

I was previously able to do nice direct import into Zotero by clicking "import into Endnote" on the Google Scholar page.
As of today, this instead tries to download a ".enw" file instead.

I know I can use the import icon on the address bar instead, but it would also be nice to use the direct link.

Any ideas? Opening the file with firefox doesn't work.
  • Actually it looks like all Google scholar translation is broken.
    Can anyone else verify?
  • URLs?
    No verify - works fine for me - both endnote import and the folder icon.
  • I had to change my scholar preferences to show the BibTeX links (rather than the ENW/RIS links) in order to get the translator working.

    I think this reflects a change to the GS translator made in mid-July.

    When I set it to use ENW links, Zotero will import them still if the "Use Zotero for downloaded RIS/Refer files" option is checked.
  • Hmm. All of them, e.g. my current page:

    The Endnote link wants to open "scholar.enw" and the Translator gives me the good-old "Could Not Save Item" error.
  • It was working fine for me yesterday, and I haven't changed anything...
    If I change it to BibTeX,it just opens the raw BibTex text-file...
  • no, for me this works with either export link shown.
    I have the customize google extension. Any chance that would _help_?
    I'm thinking that bc I also can't save my preferences, which is probably because my extension is blocking google from doing something spooky.
  • If I change it to BibTeX,it just opens the raw BibTex text-file...
    I meant to use the import link in the addressbar. Zotero does not automatically process BibTeX files from your browser.
    no, for me this works with either export link shown.
    I did notice that when I was logged out (so had no links), the GoogleScholar translator worked fine.
    I'm thinking that bc I also can't save my preferences
    I don't use that extension & am also not able to save my preferences. So maybe GS is just doing something spooky right now ;-)
  • I also use customise google (rip out the ads etc.)
    I'll do a standard Windows troubleshoot (10 minutes rebooting) and see what happens...
  • That didn't fix it... Still the same weird "scholar.enw" behaviour.
  • I assume you have the "Use Zotero for downloaded RIS/Refer files" pref enabled?

    It's most likely a GS problem, but if you like you can install LiveHTTPHeaders and check the Content-Type header of GS response. Open LiveHTTPHeaders, load up the page, clear the console, and click the Import link. The first block is Zotero's request, followed by GS's response. See what content type it's returning.
  • I think it goes deeper than this - I've upset Zotero's file-handling behaviour...

    When I double-click on a PDF, it wants to open it externally in a Adobe Acrobat, even though Firefox opens with the Adobe plugin in a new tab.

    Any smart ideas? Or do I just need to revert to my most recent backup!
  • Well I fixed the file-handling - thanks Dan.
    But the GS issue is still there.

    I've got other weirdness too - possibly related.
    e.g. I can only "Export" in either Dublin-core RDF or Wikipedia. All the other options have vanished.

    The GS content type from the direct "Export to Endnote" link is:
    application/x-endnote-refer; charset=ISO-8859-1
    and from the file icon at the top is:
    text/plain; charset=UTF-8

    There's plenty more in the LiveHTTPHeaders logs which I could post if that helps.
  • application/x-endnote-refer should import. text/plain would not.

    But the missing translators in Zotero would seem to be the issue here. First, make a backup of your Zotero data directory. Then post a Report ID from Report Errors after trying the Export link. Then click Reset Translators and Styles in the Advanced pane of the Zotero prefs, restart Firefox, and try again (and also see if the other export options are back).
  • Resetting fixed the problem - thanks Dan - should have tried that from the beginning.

    In case they are of use, the error(s) reports are:

    Report ID: 50779560 from the "Export to Endnote" link
    Report ID: 627101936 from the folder icon
  • Weird. Can you take a look in the 'translators' folder in your backup data directory and see if the BibTeX.js and RIS.js files are present (and not corrupted)?
  • No they aren't in the old backup... Don't know how I managed that...
    (PEBKAC again no doubt.)

    I have been backing up most days though, and might have done something strange during moving files etc.
    I also removed all tags the other day (as per, though I can't see how that would have messed it up.
  • I set the GS setting to show "Links to import citations into EndNote". However, when clicking on the import link, Firefox (31.0) keeps opening new tabs endlessly. I use Zotero Any ideas?

    I tried setting GS to export BibTex citations, but then I only get the text, i.e. no import.

    Could you pleas help?
  • Why aren't you just using the URL bar icon for import to Zotero from Google Scholar? That's what it's for.
Sign In or Register to comment.