problems installing MacWord integration (3.0a4) in word2004

I was just updating the zotero plug-in for MS Word 2004 on Mac. After some trouble it installed but my already installed Endnote 9 plug-in for Word2004 dissapered as well.

Some people maybe think it is ok to just kick endnote out of the computer, but I belive zotero does not need such policy. It is a good program getting continuosly better and it will convince more and more people to switch from endnote to zotero without forcing theme.

First I had installation trouble, because The Firefox-add-on could not install the word Plug-In because of writing permissions. (For security reasons I work with an "normal" (i.e. limited) account. Normally during the installation of programs a window opens to insert an administrator account name and password to write in the program folder, this did not happened with the zotero-add-on attempt to write in the Program folder) I could solve that problem by manually allowing my user-account to write in the /Applications/Microsoft Office 2004 folder in the Finder settings (-> Information....)

Second: the Word Integration finally successfully installed and seems to work. But at the same token the Endnote Plug in (Endnote 9) and tool-bar dissapeared. What seemd to happen is, that Zotero created a new subfolder "startup/word" in the existing "/Applications/Microsoft Office 2004/Office" folder. While the old zotero plug-in (for Zotero 1.0) and the Endnote Plug-in is situated in the subfolder ".../start/word". This is maybe a problem specific to non english word installations (in this case german) because the filenames maybe differ from the english de-facto-standard.

I tried to copy manually the Endnote files into the new folder created by zotero. Now the Endnote Bar appears again, but instead of inserting a note it just insert the whole bibliographic information.

While there is no solution for updating all word documents created with endnote I need to use Endnote to work on my older files while creating new ones with zotero support. So the working installation of both plug-ins is essential to me (my dissertation manuscript is 160 pages in word/endnote and I don't want to start it all again).

Unfortunatly I am not at home and so I do not have my Endnote Installation files at hand. Anybody has an Idea how to reestablish the Endnote integration? (I know this is not a direct zotero topic, but a problem caused by zotero installation procedure)

hopfully the zotero-plug-in update process becomes in the future more reliable without collateral damage to the word installation

thanks for any help
  • To anybody who suffered the same problem like me: In the Endnote installation folder I found the document "CWYW Manual Installation.txt" that helps for manually reinstall the Endnote integration. (Basically readjust in word->preferences->locations the location for the template folder). Seems to work again zotero and endnote in word.

    Anyway I hope in the future the zotero plug-in installation does not interfer into the other plug-ins.

  • Just to clarify, Zotero does not "kick out" the EndNote plugin for Microsoft Word. I'm not sure what you did while trying to install the Zotero plugin, but whatever happened had nothing to do with Zotero.
  • Or, rather, if this happens, it has nothing to do with EndNote. The problem you describe seems pretty clear—that there's an (arbitrary, probably undocumented) order of Startup folders that Word tries on non-English systems, and so if a Startup folder is present, the Start folder isn't read. We've seen similar issues on German systems, and we'll see if we can find a better solution than creating a Startup directory if one doesn't exist, but suggesting that this is some sort of nefarious "policy" on Zotero's part isn't helpful.
  • edited September 20, 2009
    I've also had a problem with installing the new MacWord integration plugin for Word 2008 on my Mac.

    Snow Leopard came with my laptop and I installed in before installing any version of Zotero. I followed Dan's directions on installing the two files into the Mac HD-->Library-->Python--2.6 directory. Zotero was working fine once I got that squared away, and then Firefox prompted me to upgrade Zotero. When I opened Word and tried to insert a citation I was getting a notice that the plugin for Office was not compatible with the new version of Zotero. I checked the website and deleted the two files that I had previously installed. I then installed the updated versions of Python and the MacWord Integration plugin.

    Zotero is showing up in my script area of Word but it will not do anything (insert citations, bibliography, etc.). Also, when I try to delete and then reinstall any of the plugins like Python (I've tried both 2.5 and 2.6) or the MacWord Integration plugin, I'll get a message on restarting Firefox that says something to the effect of "It appears the MacWord integration plugin has installed successfully, but a “necessary component does not appear to be loaded properly. Firefox can attempt to remedy this for you but it will require Firefox to restart". Once I get to this point it simply goes in a loop with the ‘zotero macword integration error” window popping up over and over again telling me that the macword integration installation succeeded, but that the necessary component is missing

    Alternatively, I will try to install Python and I get a message saying:
    “Zotero MacWord Integration requires PythonExt to run. While Python is currently installed, it appears to be corrupted or incompletely deleted. As such, Firefox Add-on manager may not be able to remove or reinstall it. Would you like Zotero Integration to remove it and restart Firefox?”

    This latter message seems to go away after one shot, and where I’m really stuck is with the error that keeps appearing to tell me that a necessary component is missing.

    Am I doing something wrong?! I’ve tried putting the two files back into the directory that I initially mentioned to see if that would work but it doesn’t—I still get that initial incompatibility message. Please Help!
  • @Dan: I did not want to express, that the zotero programming team consiously has a policy to kick out endnote. Sorry for that missunderstanding, its maybe because I am not a native speaker. All I wanted to say is, that zotero does not need such a policy because it is convincingly good in itself. And I reported that problem exactly for that you can change that behaviour in the next version even though the problem seems to be original a bad programming on behalf of Microsoft Word. From the users point of view it happens when installing/updating zotero and it would be great if zotero could handle the problem. Meanwhile I hope this discussion helps people who experience the same problem I expirienced (and resolved by installing all plug-ins in the Startup folder that zotero created)

    All the best
  • mflynn1: Please don't hijack other people's threads. Start a new one, and we'll be happy to help.
  • olaf, we've updated the MacWord installation script to check for a "Start" folder. While we don't know what other names this folder might have in other localized copies of Word, we'll add them if users report them to us.
  • Thanks for that quick response!!
Sign In or Register to comment.