Zotero beta freezes when adding/editing citation in Word (M1)

edited March 22, 2021

the recent Zotero beta freezes consistently when I try to add or edit a citation using the Word plugin. It usually works one time and freezes on the second (the color wheel appears and Zotero is unusable). Furthermore, when Zotero is not running and I click "Document preferences" in Word, Word freezes (and doesn't unfreeze upon opening Zotero).

I use a MacBook Air M1, Word 16.48 (beta channel) and a custom citation style based on "Neue Juristische Wochenschrift (Deutsch)". I cannot produce a debug ID as debugging stops when I force quit Zotero.

Edit: It does not happen on my Intel iMac with the same citation style and version of Word.
  • same problem
  • @mschwarze: Can you update to the latest beta and see if that fixes this?
  • @dstillman No, the issue persists.
  • Does this happen with other citation styles?

    If not, we'd want to see the style and a CSL-JSON export of the items that trigger this.

    For debug output, see Logging to a Terminal Window. You can post the output somewhere (e.g., Dropbox) and provide a link here or email it to support@zotero.org with a link to this thread.
  • @dstillman It happens with other citation styles also. It is always the second action taken: if I create a new Word document and open the document preferences, the first citation entry causes the freeze. If a citation style has been chosen before, the first citation entry works but not the second.

    Ok, will try to produce debug output.
  • Can we still see the CSL-JSON for the items in question?
  • edited March 23, 2021
    Actually, let's see the debug output first. It's not clear from your description that this is related to items at all. You should test with a new, empty item to see if you can reproduce it.
  • edited March 23, 2021
    It happens regardless of which item I cite. But here is one I tried, if that helps: https://1drv.ms/u/s!At2iVKW7O0Q9qXNJVkgLSHt3fDmo?e=BcIE1t

    It happens with a newly created item also.
  • @dstillman I sent you an email with the debugging output.
  • @mschwarze could you download this older Zotero.domt file and install it manually following these instructions https://www.zotero.org/support/word_processor_plugin_manual_installation then restart Word and see whether it works better?
  • @adomasven No, the issue remains the same.
  • edited March 23, 2021
    Could you try reverting to the non-beta Word and confirm it works there?

    Edit: Before reverting you could try running Word in Rosetta translation mode and see whether it works that way.
  • Yes, opening Word using Rosetta solves the issue.

    I don't think it is connected to the beta of Word as the issue appeared not after a Microsoft update but after one of the recent Zotero beta updates (I believe beta 7).
  • Exact same problem here, also on the Zotero Beta Channel, also M1 Macbook, happening since 2 or 3 days. Citation style used: The Journal of Hellenic Studies. Word-Version: latest stable build. However: Opening Word in Rosetta does not really solve the problem for me. This stops Zotero from freezing completely but still produces an error message saying the update of the document ist not possible beginning with the 2nd action I do in Word.

    Only Solution for me was going back to stable Zotero, which solved all the problems at once. This is however not ideal, as I enjoyed working with the Safari Connector and with the new pdf features...
  • same problem
  • @mschwarze, @panyuz, @marc.gehrmann, @FLIER: We've pushed a new beta that should fix this. You can update from Help → "Check for Updates…". Let us know if you still have trouble after updating.
  • @dstillman Yes, it's fixed now. Actually seems faster now. Many thanks.
  • @dstillman Thank you very much for your quick response and good work! Indeed the freezing problem seems to be fixed now. What still persists for me is the updating document error message starting with the 2nd citing action I take in Word. I will revert back to stable for now where this error still doesn't show as I have some deadlines to work. Hope you can fix this problem soon which only started a few days ago as I would love at some point to continue using the beta path.
  • @marc.gehrmann Could you submit a Report ID after receiving the error? Are you saying it is only present with the Word Beta?
  • @adomasven Sorry, I can't produce a Report ID anynmore as I'm back to the stable version of zotero for now. And no, I used the latest stable word build, only zotero ran in beta. As the problem with the document update error doesnt show up in stable zotero, all other things being equal, I figure that it must have something to do with the latest zotero beta builds.
  • @mschawrze We have now pushed some changes to the Beta release of Zotero that will hopefully not cause problems with M1 macs but fix an unrelated issue for some other Mac Word users. Please tell us if after updating Zotero you can still cite fine with Word.
  • @adomasven Unfortunately not, the exact issue reappeared. I'd appreciate a fix.
  • Hello. I am experiencing similar issues with Big Sur 11.2.3, on a Mac with an M1 chip. I regret updating since I had no issues before this.

    I’m finding that I can add or edit citations just once without issues, but subsequent calls to the Zotero connector/add-on lead to a permanent loading “beach ball” on the Zotero window, necessitating a force quit.

    I have activated Debug Logging but cannot figure out how to access the logs when I have to force quit Zotero.
  • Never mind. I find that running Word in Rosetta translation mode works swimmingly.
  • edited March 27, 2021
    @eshin21: I've moved this to the relevant thread.

    You don't want to run Word under Rosetta, so we'd like your help debugging this. Did you test this with the latest Zotero beta? Can you 1) make sure you're running that, 2) reproduce the freeze, with Word not running under Rosetta, and 3) provide a Report ID from Zotero? You can then temporarily set Word to run again under Rosetta until we have a fix for this in the beta.
  • I decided to run Word in Rosetta upon following the advice within this thread:


    I know running in Rosetta is not great performance-wise, but I guess it’s a reasonable trade off to ensure compatibility.

    I’m on the latest Zotero beta. I followed your instructions––disabled running in Rosetta, quit and re-opened Word in Universal/native ARM, then reproduced the error. This yields a frozen Zotero window, so I force quit and re-opened Zotero. Then I grabbed the Report ID. I’m not sure how helpful this is given that I had to quit the Zotero session when the error was occurring, so this new Zotero session doesn’t look like it reports an error:

    No errors have been logged since Zotero started.

    version => 5.0.97-beta.11+5e98b9c53, platform => MacIntel, oscpu => Intel Mac OS X 10.16, locale => en-US, appName => Zotero, appVersion => 5.0.97-beta.11+5e98b9c53, extensions => Zotero LibreOffice Integration (5.0.24.SA.5.0.97-beta.11+5e98b9c53, extension), Zotero Word for Mac Integration (5.0.38.SA.5.0.97-beta.11+5e98b9c53, extension)

    Report ID is 255409184.
  • No, that's fine — thanks. We'll keep working on this and post here when we have another beta update. You can keep Word under Rosetta for now.
  • Great, thank you for your help!
  • We've pushed another beta that reverts the latest changes, so you should update to that via Help → Check for Updates and set Word back to running normally rather than running under Rosetta.
Sign In or Register to comment.