Zotero Word Plugin Error Message

edited March 18, 2021
I updated the Zotero plugin for Word and ever since I get the following error message when I try to add new references: "Zotero experienced an error updating your document.
Would you like to view troubleshooting instructions?"

Some precisions:
+ The error message shows up in new and old documents likewise
+ The error message does not show up when I simply add a new reference in body text, but does show up when I want to integrate a reference within a footnot (using Chicago style).
+ Zotero ver 5.0.97-beta.5+b3e46392b; MS Word version 16.46
+ The document is saved on my local drive not OneDrive

The error started popping up after I updated the Zotero Word Plugin.

Many thanks for your help!
  • Can you provide a Report ID and the exact steps to reproduce this in a new document?
  • And what do you mean by "after I updated the Zotero Word Plugin"? That's not something you update independently of a Zotero version.
  • Hi!
    Many thanks for getting back. The report ID is 1295231307.
    I am not exactly certain, but I think at one point recently Zotero proposed to update the Word Plugin specifically. If I remember correctly the Word plugin did not appear automatically with Zotero but I needed to specifically install it.
    I did not specify earlier, but I am on Mac (ver 11.2.3).
    Thank you!
  • @adomasven will need to look into this. A Debug ID (different from a Report ID) for trying to insert a citation into a new document and getting the error might help.
  • @gustav.kalm Is this a new M1 Mac or an older one? Please submit a Debug ID (see link in the comment above).
  • Dear both,
    Thank you for your help. I tried again with a clean new document now and I do not get the error in a new document any more. However, when I tried previously, I did get the error. I tried a couple different manners of inserting references, but I am not certain what I would have done differently. Nonetheless, the problem persists in existing documents and copying the content into a new file does not help and neither does renaming the document.
    I am using a 2020 MacBook Air with the Intel i5 processor.
  • Also, one document where I was not able to insert a new citation within a footnote earlier, allows me to enter a citation now. In another document, the error persists, though. Would it be helpful if I post some report from either?
  • Actually, it allowed me to enter one citation in a footnote, but not a second one in that document. It is very hard to understand where the problem comes from as it seems that the error is not systematic.
  • I followed the Debug ID instructions in an existing document where entering a new citation within an existing footnote did not produce an error message when entering the first new citation, but produced an error when I tried to enter a second new citation. I retried adding the second citation and produced the Debug ID. Here it is D2136245219
  • If you switch to the non-Beta Zotero version does inserting citations work fine? Could you follow step 10 of debugging broken documents instructions and send an excerpt of the document where you can reproduce the bug to us?
  • I tried switching to the non-beta version, that is I reinstalled Zotero from your website. Now Zotero will not even open. I get the following error message: "This Zotero database requires Zotero 5.0.97-beta.1+586a6f1dd or later.

    Current version:

    Please upgrade to the latest version from zotero.org."

    None of the options "More information", "Cancel" or "Check for Updates" allows me to access my database now.

    I never wanted to use a beta version in the first place. Somehow Zotero just kept automatically updating itself and I already found it annoying that I needed to restart it every now and then because it had downloaded an update behind my back.

  • I googled Zotero beta and was able to download the beta version. How to revert back to the non-beta version, though? I would much prefer that, anyway.
  • Just download the regular Zotero installer and run it. Your data won’t be affected.
  • This is what I did first and this lead to the following error message: ""This Zotero database requires Zotero 5.0.97-beta.1+586a6f1dd or later.

    Current version:

    Please upgrade to the latest version from zotero.org.""
  • Yeah, unfortunately it's currently impossible to easily switch to the stable version of Zotero if you've been running the Beta. You will either need to restore from a backup before you started using the Beta or sync your citations with your Zotero account with the current Beta then move away your Zotero database (keep a backup just in case), install the stable version and re-sync your account.
  • edited March 31, 2021
    @gustav.kalm: Note that Zotero makes an automatic backup during the upgrade process. If you want to switch back, look for a zotero.sqlite.109.bak or similar file (check the file timestamp) in your Zotero data directory. Swapping that in for zotero.sqlite with Zotero closed will give you your data from before the upgrade without needing to pull down your entire library. As long as the beta version was fully in sync, any changes you've made since the upgrade will be automatically pulled in on sync.
  • Thank you both for your help and comments.

    Restoring from an online backup seems not to be the best option as it would cost me $120. I normally only sync the titles with the online library as I only use Zotero on one computer, have a library that is 14gb+ (a decade worth of pdfs and annotations) and make regular backups anyway and have hence not wanted to pay the $120 fee.

    Going to the pre-beta version of my library does not seem a good option either as I honestly do not know when I installed the beta. Probably it was required for one of the plugins and stupidly chose the beta version which has been rather annoying because it keeps updating itself and asking me to restart Zotero all the time.

    I will try step 10 of debugging broken documents suggested by @adomasven above and will report back.

  • edited April 1, 2021
    Restoring from an online backup seems not to be the best option as it would cost me $120.
    No it wouldn't. This is about data syncing, which is free and unlimited. But restoring from the local upgrade backup file would be trivial, and that would be the quickest thing to do if you wanted to go back.

    Either way, while we'd be grateful if you'd follow the debugging steps and provide a document excerpt, after that if you don't want to be running the beta software, there's really no reason not to switch back.
  • I am sorry, I was confounding different terms earlier (sync vs backup, data vs entries/items vs attached files).

    Re return to non-beta:
    If I understand correctly, when I delete the zotero.sqlite.109.bak or similar file in my data directory with Zotero closed and then reinstall Zotero normal non-beta version and sync it, all my library entries would reappear. Does this also apply to the files that I have associated with each entry/item in my library. As I understand it, I have not purchased the space to sync the associated files but only the entries/items. Would Zotero be able to pull the associated files from my data directory after syncing?

    Re error message when entering citations:
    I followed the step 10 from the debugging instructions and got the same error message on both halves of the document when I tried to replicate what I had done that is create a footnote and enter in it two citations from the same author with "suppress author" and with prefixes to both citations. Any citation I tried to add after this always produced the abovementioned error. However, I did not get this error in a new document when I tried now.

    Should I email the document to support@zotero.org referring to this thread and the report and debug IDs produced here?

    Many thanks!

  • when I delete the zotero.sqlite.109.bak or similar file
    No, you're misunderstanding. You don't delete that file. That's your backup file. Zotero loads zotero.sqlite in that folder at startup. So if you want to restore to that backup, you would move the existing zotero.sqlite out of the way and copy zotero.sqlite.109.bak into place as zotero.sqlite.

    This has nothing to do with attached files, which won't be affected.

    And again, this assuming you're in sync in the beta, so that recent changes are pulled down after you restore from the backup.

    Re: the steps, you have to narrow down the document to the smallest possible section that 1) reproduces the error and 2) you're comfortable sharing with us. The email address is just for sharing the file.
  • Thank you!

    1. Ok. So I should remove the current zotero.sqlite file and then rename one of the .bak files as zotero.sqlite and then reinstall the non-beta version. Is that correct?
    [I am keeping an external backup of the Zotero data directory in any case]

    2. The error reproduced itself in either portion of the document. That is deleting one half or the other, the error still produced itself when I tried to do the mentioned procedures. I am fine sharing the whole document.
  • 1. Yes, that's correct.

    2. You can send the whole document, then.
  • fyi: I also found a workaround for the issue. If I need to enter a reference within a footnote, I just add citation in body text which creates a new autonomous footnote and I copy-paste the reference from there into the text of the already existing footnote as I was seeking to do originally. This is of course just a workaround and I'd much rather solve the issue.
  • @gustav.kalm I cannot reproduce the issue in the document you have sent us. Could you say precisely where and how you insert the Zotero citation to receive the error? Do you only get the error if you insert the footnote manually? Is there a difference based on whether there is any text in the footnote or not?
  • Hi there, was there any resolution to this issue? I am having a similar problem to what gustav.kalm described where I am not able to add second citations within a foonote. This has happened to me in two separate documents, but I was not able to successfully reproduce the issue in a new document. I can figure out some workarounds and/or create a new document and redo citations for now, but wanted to report here to support the effort to figure out what is going on. I restarted Zotero and reproduced the issue in my document, and submitted an error report with Report ID 845381858 and a debugging log with the Debug ID D479399338. I am happy to send a copy of the document as well if that would be helpful.

    Thank you!
  • @kumarhk There's no progress on this issue. We need to have a way to reliably reproduce the issue in some document to be able to fix it. If you are able to produce a document snippet where you can reproduce it 100% of the time, please send it to support@zotero.org with a link to this thread. Please also say what version of macOS and Word you are running (full version numbers).
  • Thank you for your response, @adomasven, and sorry for my late reply in return. I tried to reproduce the issue in a new document, but I wasn't able to do so. I'll try some alternate configurations in the coming days and will send a document and the other info that you requested if/when I can reproduce it.
Sign In or Register to comment.