Run-time error '5': Invalid procedure call or argument

This discussion was created from comments split from: Run time error 5, invalid procedure call or argument.
  • I have the same issue. I believe it started when Zotero was updated through auto-update. I haven't been able to find a solution yet.
  • @kobatan did you find a solution?
  • Zotero 5.0.96 fixed one major cause of this — it shouldn't have caused it.

    @arshiasobhan: What's the full error that you're getting? There should be a debug button that lets you open the Visual Basic console, which should show you the line where the error is occurring. Can you paste that in?
  • @dstillman thank you for the reply.

    The full error is: Run-time error '5': Invalid procedure call or argument.

    The Debug button is there, but it is disabled.
  • What macOS version and exact Word version? And can you provide a Report ID from Zotero?
  • I'm using:
    macOS Catalina 10.15.7
    Word 16.46 (21021202)

    Report ID: 1099239982
  • OK, @adomasven will need to look into this. I'm not sure why the debug button is grayed out, but I suspect we'll need to figure out how to get that enabled for you — something related to VBA in Word — in order to troubleshoot this further.
  • Thanks, I really appreciate it.
  • Download this file https://www.dropbox.com/s/39ml5j0bx61cyy7/Zotero.scpt?dl=0 and put it on your Desktop. Make sure Zotero and Word are open. Then open the Terminal.app and run the command bellow:
    cd ~/Desktop && osascript Zotero.scpt "PIPE=\"$HOME/.zoteroIntegrationPipe\"; if [ ! -e \"$PIPE\" ]; then PIPE=\"$HOME/Library/Containers/com.microsoft.Word/Data/.zoteroIntegrationPipe\"; fi; if [ -e \"\$PIPE\" ]; then echo 'MacWord16 addEditCitation /Applications/Microsoft Word.app/' > \"\$PIPE\"; else exit 1; fi;"
    You should see Zotero initiate the citing operation on your open Word document if it is successful.
  • Hi I am getting the exact same error including debug being grayed out and it is ruining my life.

    I just reported the error through zotero. Report ID: 440810759.

    I'm running:
    MacOS Big Sur v11.2.1
    Microsoft Word for Mac 16.46

    I downloaded the file and ran the above command from the terminal. The citing operation window opened and it worked for adding one citation. I am in the same document and went to add another citation and it didn't work. I can't run that code for every citation.

    Also, as you'll see in the error report I am currently working with the Big Sur beta as I thought maybe that was the problem. I had the same error from both the newest version of Zotero and when reverting to the beta.

    Rebecca

  • edited March 2, 2021
    @stubbsrl If you download this old Zotero.dotm file, place it in the Word startup folder, which should be ~/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word and restart Word, does the plugin work?
  • Yes that worked! Thanks!!!
  • OK, thanks. We've released Zotero 5.0.96.1, which fixes this problem. (It won't make a difference for you now, since it just switches back to that older template file.)
Sign In or Register to comment.