Zotero integration error in one computer but not another

I have suddenly started getting the standard Zotero integration error box pop up on one document which I have been working on for months. The problem seems to have been caused by using track changes (as in the troubleshooting guidelines), so I accepted all changes, switched off track changes, rebooted and tried again. Still the same problem.

I then tried opening the document on another computer (same version of Word, same Zotero) and everything works perfectly, and I can insert citations. So I saved the document and reopened it on the first computer, and the problem reappears.

Seems to be some configuration problem? Anyone any ideas?
  • We'll need more info about said configuration? What OS'es, which versions of Word, Zotero, etc? Also submit a Report ID from the system where you are seeing the problem.
  • OK,
    Report ID: 675388036

    Both running:
    Windows 10, 20H2, build 19042.804
    Zotero 5.0.96

    Word, On malfunctioning PC: v 2101, build 13628.20448
    Word, on functioning laptop, v 2008, build 13127.21216
  • Is the document saved on OneDrive? Did you try saving it on the local disk and/or saving it without spaces in the filename?
  • Removing spaces solves the problem. I do use OneDrive to synchronise between the two computers, but always store files locally and open them from the hard disk rather than the cloud version, but in the two years I have been using Zotero have never found this to be a problem. It is also puzzling why my normal configuration and file name works on one computer but not on another.

    The inconsistency is very confusing. Any thoughts why this may happen?
  • We've been trying to get to the bottom of this for a long while, but we just cannot reproduce this ourselves. The differing Word versions may very well be the cause too.

    Could you produce a Debug ID from both computer trying to cite the same file placed in the same location on OneDrive with spaces in the name where it fails on one and succeeds on the other? For the computer where you get the citation dialog just cancel it by pressing Escape, for the other computer, click through any dialogs you see before submitting.
  • Hi, I have just reproduced the problem, using a different file than the one that caused the problem yesterday, but is showing the same symptoms. Again, this is a file where the filename has spaces in it. You will receive two debug IDs:
    D1252993192, from the computer where there is a problem and the integration error window pops up.
    D1378215748, from the laptop where it works perfectly.

    I will be interested to hear if you can make any progress based on these logs.
Sign In or Register to comment.