Citations immediately unlinked on Google Docs/Chrome

Hi,

I'm having a problem with Zotero and Google docs (using Chrome/Windows – this bug does not occur in Firefox/Windows). Almost every time I add a citation it is added already unlinked/it becomes unlinked immediately.

I've tried this on about 5 new Google docs, and across different Google accounts - it happens in every one. I've also disabled Google docs offline, as I saw on another forum thread that might cause these problems - it didn't fix the issue. I've tried it with a number of different referencing systems, including Nature and Cite Them Right 10th Ed Harvard, and with many different citations.

Steps I took:
1) Opened Google Doc.
2) Clicked Zotero->document preferences, and selected referencing system.
3) Typed a sentence.
4) Ctrl-Alt-C to add a citation. Typed in the source name. Selected it using enter. Pressed enter again. (This citation enters correctly).
5) Type another sentence.
6) Step 4 again. (This time, the citation was unlinked).

Report ID (via Chrome Zotero Connector): 916091772.
  • When you say unlinked, do you mean that you got the notification in the top right that it was unlinked, or did it just become plain text?
  • I didn't get a notification, it just became plain text. That particular citation also didn't appear in the bibliography when I generated one.
  • OK, this is due to a bug in version 5.0.80 of the Zotero Connector — we haven't been able to reliably reproduce it in Chrome, but we were able to reproduce it in Edge.

    We've already submitted 5.0.81 with a fix, but unfortunately Google can take a few days to approve new versions. (We actually fixed this in Firefox, Edge, and Safari before 5.0.80 was even approved for Chrome, but we weren't able to cancel the Chrome submission.)

    If you're seeing this regularly, you can temporarily switch to Firefox or Edge until 5.0.81 is out for Chrome. We'll post here once it's available. Sorry for the trouble.
  • I had a feeling it might have been to do with the new version - it's not a problem, I'll just use Firefox in the meantime. Thank you for looking into it and letting me know!
  • I'm experiencing similar issues with Zetero/Google Docs as described by other users. New links not linking and ones that were linked unlinking. Please let us know when the bug is sorted.
  • @curleyk Could you submit a Report ID from the Zotero Connector?
  • Report ID: 1733103442

    I am getting notice saying "that the following documents have become unlinked" when I try to relink them, I get a message saying "document updating" but nothing happens - the progress bar appears to show that something is happening but nothing does. I am relatively new to Zetero so any advice is welcome.
  • This is a Report ID from Zotero, could you produce one from the Zotero Connector?
  • Oops! sorry. Here is the report from Zetero Connector
  • Now here is the ID report

    Zetero Connector report ID: 1128718053
  • Having the same problem as OP - all of my citations added yesterday immediately turn to plain text. Anything before yesterday is still working fine.
  • See my message above:

    https://forums.zotero.org/discussion/comment/374370/#Comment_374370

    This will be fixed as soon as Google approves Zotero Connector 5.0.81. For now, you should use another browser.
  • Thank you, much appreciated.
  • Hi, I am having similar problems when adding citations on a google doc using the Google chrome browser. After inserting the first citation, the next one is added with the number (1), instead of (2).
  • Same problem here (Chrome on Mac). I have a paper with 170 citations and I wasted DAYS between time do add/edit citations (1+min per citation) and random unlinks and now this plain text issue is such a pain that I will definitely NOT recommend zotero+gdoc to anybody.
  • @marco.pritoni: Once again, we fixed this immediately for all other browsers, but we have no control over how long it takes Google to approve Chrome extension updates. You can use another browser for the next few days if you're experiencing this.

    If you're getting slow inserts in a large document, disable "Automatic citation updates" in the plugin's Document Preferences window for faster inserts. Start a new thread if you're having trouble with that.
  • I am glad I found this post! Same problem immediately with unlinked citations, Mac and Chrome. Zotero connector Report ID: 1621780105. Every 10th citation is inserted correctly, so that is the strange thing. I will wait for the Chrome update in order to fix it all. Thank you.
  • Such a relief to know that it is going to be fixed! I have recently known Zotero and really loved it. This bug was just causing me to go back to the EndNote nightmare.
  • edited 18 days ago
    This bug was just causing me to go back to the EndNote nightmare.
    Given that EndNote doesn't work with Google Docs at all, that wouldn't make a whole lot of sense. Zotero's Word and LibreOffice plugins aren't affected by this bug.
  • Zotero Connector 5.0.81 for Chrome is available now with a fix for this bug. You should be upgraded automatically within a few hours, or you can open the Chrome extensions pane and click Update. Then reload Google Docs.

    Sorry for the inconvenience, and let us know if you run into any further trouble.
  • Delighted to be up and running again with Google Docs/Zetero. Thanks to all the team for getting the issue sorted.
  • I add my thanks to those of Curleyk.
    Although I continue to use Edge, as it has shown to be faster at re-establishing the connection when using Docs, which makes all the difference due to the current instability of my internet connection.
Sign In or Register to comment.