Can't get workarounds for M1 Mac to work

This discussion was created from comments split from: Cannot add or edit citations (macOS Big Sur + Word + M1 Mac).
  • I have a macbook air M1, where the Zotero program does not work. From the first time I tried to use it, it told me that word was not compatible with zotero, at least the version I installed on my macbook. I followed the instructions on the zotero page and returned to word 16.43, where Zotero did not work either. Reinstall word 16.44 with zotero and it was working fine for a few days, but today Zotero stopped saying the following: Due to a bug in macOS, Word must be adjusted to work with Zotero on Apple Silicon Macs.
    I contacted Apple and they told me the following: "If their driver is not compatible with Big Sur, you can ask when it will be available. That’s about as far as we can help with that issue".
    Thus, I ask you in the most careful way, when the driver will be available to be able to use zotero with apple M1? Mainly, to take into account the date and decide whether to wait or look for other alternatives to be able to integrate references to my word texts.
  • edited January 18, 2021
    @cruzgalfredo: You're doing one or more things wrong here.
    I followed the instructions on the zotero page and returned to word 16.43, where Zotero did not work either.
    No, it absolutely works with 16.43 — 16.43 was the stable version of Word used by all users before 16.44 was released, and it worked fine, and many people in this thread have fixed this by reverting to 16.43. You may be experiencing some other unrelated problem, but it's not this problem.
    Reinstall word 16.44 with zotero and it was working fine for a few days
    No again. 16.44 won't work at all on an M1 Mac, for any period of time, unless you run it via Rosetta, in which case it will work fine.

    Apple Support doesn't know what they're talking about — there's no "driver", Zotero is perfectly compatible with Big Sur, and this is a bug in macOS with M1 Macs that we've already reported to them as FB8943158. But the workarounds on our support page absolutely work. If you're having trouble, start a new thread and explain exactly what you've done and what the problem you're currently experiencing is. If you're getting "Due to a bug in macOS, Word must be adjusted to work with Zotero on Apple Silicon Macs", it just means you're running Word 16.44 or later and not running it via Rosetta.
  • You are totally wrong, as I wrote in the message, I have faithfully carried out the steps to resolve the conflict for Zotero and apple M1 as the Zotero page and you mention it and it still does not work.
    You are also wrong if you say that Zotero does not work at all in Word 16.44, because in my case it works well as well as version 16.43. However, the operation only lasts a few days, and then it stops working again.
    It seems to me that both Apple and Zotero have to get to work to be able to solve the apple M1 conflict with Zotero and not have to be returning to the previous version of Word to work, which in the end, as mentioned, is useless absolutely nothing since the conflict continues to exist both using Word 16.43 or using rosetta.
    It would be good that before you write so categorically about how to solve the problems you should first inform yourself about what is really happening with Zotero and apple M1.
  • @cruzgalfredo dstillman is the lead developer of Zotero. I can promise you he knows what he is talking about. We are happy to help you, but please take a minute to collect yourself and respond calmly.

    As Dan says several times, the core issue happening is that there is an Apple bug where more than 2048 characters cannot be passed between Rosetta and native apps. If you are running Word 16.44 natively (not under Rosetta), there is no way that Zotero could send a citation to Word unless you are coincidentally citing items with very short metadata.

    If you are really sure you are running 16.44 as you describe, can you take a screenshot of the About Word window showing the version and the settings window showing that the Run under Rosetta option isn’t checked, then upload to Dropbox or similar and post a link in a new thread?
  • I don't know how to use Rosetta, so I used Word 16.44 natively, your assumptions are wrong.
    I'm sorry but I don't have time to experiment with new things to make Zotero work, my best option is to stop using Zotero and look for new ways to reference my texts.
  • Last I checked, none of the other reference managers were working natively either, so I suggest you take a minute and answer the questions Dan asked above. This really will be an easy workaround if you try.
  • I am expressing myself in a calm way and without eagerness to affect anyone. However, dstillman thinks I'm doing the process the wrong way, when uninstalling and installing an older version of Word is extremely easy. I understand that no referral program works, but that does not imply that I can do it any other way. Anyway, I hope dstillman takes a minute to calm down and respond calmly, to show his expertise.
  • I've moved this to a new thread to avoid cluttering up the original thread, where no one else has reported any problems with the given workarounds.

    @cruzgalfredo: We're happy to help you here, but you'll have to accept that, as the people who make Zotero, we know what we're talking about. If you keep refusing to accept what we tell you and won't provide any of the information we ask for to troubleshoot whatever issue you're actually having, you're going to be banned from posting here — it's a waste of people's time to spend time responding to you.

    Again, the two workarounds given absolutely work. 16.43 has always worked. 16.44 and later will not work when not in Rosetta mode. If you were using an older version of Zotero, a few smaller citations might have been inserted, but anything larger would freeze — that's the Apple bug here — which is why current versions of Zotero will show the "Due to a bug in macOS, Word must be adjusted to work with Zotero on Apple Silicon Macs" message when you're not running Word via Rosetta.

    If you think you're having some different experience, explain what exactly you're doing and what's happening, and provide links to screenshots showing both so that we can help you understand what the issue is.
  • It seems to me that all the time I have been giving you information about what is happening.
    Once again, I have installed Word 16.43, yesterday and last week, Zotero worked fine while I did not turn off the computer, I cannot keep the computer on all the time, so yesterday I turned it off and today it did not allow me to enter any more references.
    Again I was using Word 16.43 as mentioned on the page and it appears "Due to a bug in macOS, Word needs to be adjusted to work with Zotero on Apple Silicon Macs"
    Remember that it is also a waste of time for me, to be installing and uninstalling 16.43.
    I did not work with rosetta because Zotero is supposed to work excellent with Word 16.43.
    The problem, I think, is that you think I am still working with 16.44 or 16.45, but in truth I follow the indications as shown on their Zotero page. From there I have directed to download word 16.43.
    Of course, it may have worked great for others all the time but it doesn't work for me, even a few hours ago the computer crashed because I uninstalled and installed Word 16.43 for the umpteenth time.
    I repeat, it is not my intention to waste your time and when I say that Zotero does not work at 16.43 it is because I have corroborated it several times.
  • edited January 19, 2021
    What you describe is exactly what would happen if Word 16.43 auto-updated to 16.44 or later. You need to temporarily disable auto-updates, or set updates to manual and reject them for now, to keep using 16.43.

    If you think you're still running 16.43 and getting the error, provide a link to screenshots or screen recordings of the About pane from Word, showing what version you're running, and the error you're getting from Zotero.

    If the auto-updating is presenting a problem, it is trivial to run 16.44 or later under Rosetta. It's literally just a checkbox, and we say exactly how to do it on the support page.
Sign In or Register to comment.