Cannot add or edit citations (macOS Big Sur + Word + M1 Mac)

edited December 16, 2020

after the latest Word-Update (now: 16.44) I cannot add or edit citations anymore.
Whenever I click the button (no matter if I am currently within an existing citation or if I am trying to add a new one), the Zotero Popup-Window appears, I can also pick my paper , but when I hit "Enter", the Popup turns all red and nothing happens.

What I have already tried:
- Restart Computer
- Trying another document
- Trying a blank document
- Trying to cite another paper
- Reinstall Word + Zotero + Connector
- Install Zotero Beta

My current workaround is to use a virtual machine with Windows 10 with the same document. Everything works as usual the, but that's not a permanent solution.
  • Could you submit a Report ID after reproducing the problem from?
  • Report-ID / Bericht-ID:


    I found another workaround for me. As the problem came up after the Word-Update 16.44, I used my time machine backup to go back to version 16.43, switched to the regular zotero version (instead of the beta version) and everything works fine again. Maybe it’s slightly slower than before, but maybe it’s just my opinion.
  • And you don't get a popup in Word about an error that has occured? The Zotero progress bar freezes? Does Word work fine in that state? How do you get things to unfreeze from that state? Is closing Zotero the only option?
  • I got a popup in Word, but it took about 1-3 minutes to appear.

    The Zotero progress bar didn't even come up. The moment I hit the "Enter" button, the Zotero popup-window turned red and nothing happened.

    The only way to get Zotero work again was either wait until the Word-popup came up or to shut down Zotero via the macOS-Tool "Aktivitätsanzeige". Zotero won't let me close it, I just received the macOS "waiting icon" (the spinning cycle).
  • Could you take a screenshot of the "red" popup and upload it somewhere? Is macOS up to date? Have you tried updating? This isn't a regular error we've seen before (it's an OS operation timeout while attempting to set the field code for a citation), but we've been getting a lot of unregular errors lately with Word for Mac.
  • Here is a link for the red popup:

    Yes, macOS is up to date (Big Sur).

    As I mentioned - After "downgrading" MS Word to version 16.43 everything works fine again. So maybe there has been changes in Word for using fields.

    Also, maybe it's important, that I'm using a MacBook with the new M1-Chip instead of an Intel-Version.
  • Yeah, the M1 chip might very well be causing issues. Out of curiosity, for how long have you been using Zotero (and Word integration) with the M1 MacBook?
  • I have been working with the M1 MacBook about 4 weeks now. It was actually working quite fast comparing to my old MacBook, and with no issues at all, until this MS Word-Update.

    So for me I can work with the Downgrade-Workaround for now.
    But is there anything I can do to help you with this, as you receive many of these errors lately?
  • This is the first error of this type. We have developers with the new M1 MacBook that can debug the error, but we'll post here if we need more info or help troubleshooting. This might also get resolved by Apple or Microsoft too.
  • I just wanted to add that I have the same issue. M1 MacBook that worked fine until updating to the most recent version of Word. Unfortunately I don't know if I have a time machine backup or not (looking into it), so I might have to use my other machine for the time being.
  • @jarrodbcall
    Right now I‘m posting from my phone, so I can‘t try it myself, but you could try to Download the older version of the office package (for me, Version 16.43 works fine again) .
  • @tobiaski You are a life saver! That worked great! I am in the middle of comprehensive exams for my PhD program and was about to have a fit over this haha. Thanks!
  • Hi all - having exactly the same issue using the newest Big Sur macOS and an M1 MacBook. "Red popup" box as I try to add specific citations, followed by a timeout.

    Some of my citations will add properly, but others will not. I have isolated the citations which appear to be problematic and have deleted the Zotero files and recreated them and the problem persists.

    Oddly, I experienced this first when dealing with a group of citations. I can add citation A fine alone, citation B fine alone, citation A and B together fine. I can also add citation C fine alone, but if I try to add the full group, ABC, the crash occurs.

    I have also submitted an error report, 348751807
  • Hi,

    I also have the exact same problem tobiaskl describes here. I also use one of the new M1 Macbooks and just upgraded to the 16.44 version of MS Word, which now runs natively on the M1 Macs and not via Rosetta2. I wonder if this may cause the problem. Unfortunately I don't have a Time Machine Backup and found no workaround yet.
  • tobiaskl, I have the same problem under Apple silicon M1. How did you get back to word 16.43?
  • the 16.44 version of MS Word, which now runs natively on the M1 Macs and not via Rosetta2. I wonder if this may cause the problem
    Yes, the switch to an M1-native version of Office yesterday is definitely what caused this. Zotero has been working fine with the Intel version of Office via Rosetta 2.

    We're investigating this to see whether we can fix it on our end or if it needs to be fixed by Microsoft or Apple. We'll have an update soon.
  • I had this same exact problem on my new M1 Mac and reverting back to Word 16.43 did the trick. Looking forward to the fix that allows us to keep updating Word and using Zotero!
  • Hi all - same problem here with Word version 16.44 and a MacBook Air M1. What "fixed" it for me, is to change this new Word version to run in "Rosetta Mode". Just go through the instructions found in:

    Thus I can confirm, it is not a 16.44 version, but a native M1 App Issue. Please fix that properly - since the benefits of running word natively on this chip are greatly appreciated. Thanks!
  • edited December 17, 2020
    What "fixed" it for me, is to change this new Word version to run in "Rosetta Mode".
    I'd discourage people from doing this. While it will fix the problem, it will cause Word to run much more slowly, and even once this is fixed you may very well forget to go back and uncheck that box, causing Word to run much more slowly for the indefinite future (potentially for years, until Apple finally removes Rosetta 2).

    I'd recommend simply going back to 16.43 until this is fixed. 16.43 will also run slowly, but you'll be periodically reminded to update, and you can just say no until this is fixed.

    If you do switch Word back to Rosetta Mode, please be sure to set a reminder to come back here and check on compatibility so you don't leave it running under Rosetta forever.
  • edited December 17, 2020
    I have the same - new macbook air with an m1 chip - installed the latest version of word (16.44) and getting the red box when adding a citation. I'll roll back to 16.43 too!
  • edited December 17, 2020
    Update: We've narrowed this down to a bug in macOS, which we've reported to Apple. We're going to see if we can work around this in the meantime, and we'll post back here as soon as we have an update.

    For now, you can fix this by reverting to Word 16.43.

    (Technical details, for the curious: Zotero uses Apple Events to communicate with Word, and trying to pass 2048 (2^11) or more characters of text via an Apple Event running under Rosetta to an Apple Silicon–optimized app results in a freeze. The same thing happens trying to pass 2048 characters in an AppleScript from Script Editor to TextEdit when Script Editor is set to run under Rosetta. It doesn't happen when both apps are running under Rosetta, as was the case before Word 16.44.)
  • Same problem. I have a New Mac Pro M1, at the beginning all was perfect but after Word upgrade Zotero crash unable to sync the old word doc with the program. I want say that seems that on new files it works, if I create a new word doc I can insert quotation by Zotero, the problem its with older files. I have try everything, I have lost a day but I could not be able to solve the problem. Pls if is possible to find a solution...Could be a problem connected with the macro plugin? Why on new word doc it works and crash on earlier? Thx for your job!!
  • edited December 17, 2020
    Elia: See my comment immediately above yours. This is all explained, and a workaround is provided. It has nothing to do with different documents — it's with the size of the underlying citation data.
  • I have had the same issue, and it is solved by running Word in Rosetta mode as mentioned above. Even then, though, it doesn't run quite as well as it did under Intel. Sometimes it just doesn't seem to work anymore and I have to restart Word and Zotero again, after which everything is fine again.

    Anyway, I guess most Zotero users on M1 who don't look at this forum or didn't come up with the Rosetta solution themselves are panicking right now.

    The best way to fix all this would be to make Zotero a universal binary asap. Now that Firefox, Chrome, Office,… are all universal, it would make sense for Zotero to follow as well. This would also give a nice performance benefit for both Word and the Zotero client.

    I know you're all busy, it's almost Christmas, et cetera… We all understand, but just to let you know, for us M1 users, we're really looking forward to this! ;-)
  • I have downgrade Word to 16.43. Now all works (quite slow maybe). But the old word text now is able to match again the references toward Zotero. (Fiuuuuuuu :D ) .....

    May be I'll check here for news, waiting for them I ll go on with Word 16.43 avoiding all kind of upgrade.

    Thx a lot for this service!
    Last night u had been here like a light in darkness, I had quite lost hope to save my doctorate references.
    see u
  • edited December 20, 2020
    @DutchJurismUser: Please see my warning above about running Word in Rosetta, and set a reminder to not leave it like that. Again, we don't recommend that option for that reason.
    The best way to fix all this would be to make Zotero a universal binary asap. Now that Firefox, Chrome, Office,… are all universal, it would make sense for Zotero to follow as well.
    We will, but it's going to be a while. Zotero is based on Firefox, but upgrading to the just-released version of Firefox that supports Apple Silicon will take a huge amount of work, and the functionality that this feature depends on actually hasn't yet been updated, so an Apple Silicon version of Zotero still wouldn't work at the moment.

    We're still working on a workaround for this.
  • @dstillman thank you for the response. I use the Mac App Store for Microsoft Office so I don't know how to downgrade. Anyway, as soon as this is fixed I won't run Word in Rosetta mode anymore of course.

    And I do understand making a universal binary will take a lot of work! First step is of course to make Zotero work flawlessly under Rosetta. Ideally we will only have to run the Zotero client in Rosetta and not Word, so hopefully the Word issue can be fixed!
  • Same for me, same issue with Word 16.44. Downgraded to 16.43 and everything's fine. Thanks @tobiaskl
  • In Zotero 5.0.94, available now, we've added a warning when trying to use Zotero with Word running in Apple Silicon mode. The warning links to a new documentation page explaining the issue and the available workarounds.

    Unfortunately, we don't think we can realistically work around this bug in macOS and will likely need to wait for Apple to fix it. It's not yet fixed in the first Big Sur 11.2 public beta, but we've escalated this through Apple's developer channels and will try to get someone's attention before 11.2 is released, likely sometime in January.

    Sorry for the inconvenience this has caused. Fortunately, there are a couple easy workarounds until we can get this fixed by Apple.
  • > We will [update Zotero with native M1 support], but it's going to be a while.

    Out of curiosity, what kind of timescale are we talking? Weeks? Months? Years?

    (I'm a big fan of Zotero so thanks for your hard work on it all + happy chirstmas to you all)
This discussion has been closed.