Visual Basic for Applications error with Word for Mac

This discussion was created from comments split from: Cannot add or edit citations (macOS Big Sur + Word + M1 Mac).
  • I downgraded to Word 16.43 and it worked -- for a while. But now after coming back to my computer, I am getting a different error message saying that Zotero could not perform the action. "If you have performed a custom installation of Office, you may need to run the installer again, ensuring that Visual Basic for Applications is selected."
  • This error is likely to be unrelated to the issue with M1/Rosetta. Have you tried restarting your computer? Does it work in a new document or existing document? Could you produce a Debug ID from Zotero for an attempt to perform an operation that fails?
  • edited 18 days ago
    When I downgraded Word to 16.43, I knew enough to turn off automatic updating for Office apps. It turns out that the error came only while the Microsoft Auto Update app was open in the background (even without DL’ing anything). After closing the update window, Zotero functioned normally again. So related, but not related.
Sign In or Register to comment.