Zotero won't accept username and password for syncing

This discussion was created from comments split from: Zotero won't accept username and password for syncing.
  • Hi there,
    I'm having the same problem. kimwc, can you tell me how you resolved it?
    Thank you!
  • @kpopper: Can you say more about what you're trying and what's happening?

    Can you also provide a Debug ID for the operation that you're having trouble with?
  • Zotero on my desktop gives me an Error pop-up window when I enter my username and pw and hit the set up sync button. Very strange as I logged out and back in online to be sure it's the same UN and PW. Also uninstalled, reinstalled Zotero and rebooted and tried multiple times again , both typing and using copy and paste for my pw with same result. The only difference is Online my login is my email address, although in the settings online it does show the username I'm trying to use on the desktop Zotero. Also, I have two group libraries that show up with my account online - one from a couple of years ago (not essential anymore, was originally set up with a different email address) and a new one, shared with me last week. But I included both email addresses in the account, now switched to my current one and another alternative before deleting the old email address as I no longer have access to it. I'm guessing it's somehow to my original email address, but no idea what the specific problem is or how to fix it.

    Debug ID is D1862270258
  • edited December 12, 2020
    This really just means there's a problem with the username or password you entered. And the debug output shows the username you're posting from. (We don't log passwords.)

    Clear both the username and password box, restart Zotero for good measure, and try again.
  • I've tried that a dozen times, both before and after restarting the computer. The password is definitely the same online and on the desktop as I'm just using cut and paste function. Should I try changing my user name online and then try the new username on my hard drive?
  • What do you mean by cut and paste? One doesn't usually cut a password from somewhere. You should be carefully typing manually or (ideally) copying straight from a password manager.
  • Copying from a password manager. Have done it for the online account no problem, used the same for decktop, doesn't work. Will try resetting it online then using new one on desktop.
    Is there a chance the email address is preventing the sync since I originally signed up online with a different email address (and on a different computer) a couple of years ago? I did take the step more recently to switched my primary Zotero email to the current one.
  • Changing the pw worked. No idea why, used the same process from my pw manager, but at least I'm in! Thanks for helping troubleshoot!
  • My sync will not work and I tried the change of password and it still will not work. Any other solutions?
  • No other answer here. If you're having trouble, change your password on the site and try again.
  • I figured it out. My login ID (email) and password to login to the web-based Zotero account is not the same as the Zotero account username and password. The web login ID is different than the username. Why this is the case I don't know. I believe I can login to my web-based Zotero account using EITHER my email OR my username (which are different). However, once I logged into my web Zotero account - after some time -- I saw my Zotero ID, which is not an email address but just a username.
  • @coliver6: Syncing was accepting usernames and primary email addresses but not secondary email addresses. We've now fixed that, so it's now possible to use secondary email addresses to set up syncing. Thanks.
Sign In or Register to comment.