Retrieve Metadata for PDF creates automatic tags even when pref is off

This discussion was created from comments split from: Automatic tags.
  • @juliemorris: You should try to provide steps to reproduce the issue. As adamsmith writes, your observation might be unrelated to importing a RIS file. BTW, did you uncheck the option "Automatically tag items with keywords and subject headings"? See the links below.

    @dstillman: I noticed an issue with undesired automatic tags that seems to be related to Zotero's function "Retrieve Metadata for PDF". (This might not be the cause for the issue above, but some of the steps and links below might provide additional hints.)

    Steps to reproduce

    1. In Zotero's General preferences pane, remove the check mark for "Automatically tag items with keywords and subject headings". Make sure that the option "Automatically retrieve metadata for PDFs" is checked.

    2. Open this PDF file in a web browser and add it to Zotero with the connector button, which shows a PDF icon. (I used Firefox for this.)

    3. Zotero creates a parent item for the PDF attachment which has some automatic tags. I would expect none from the settings in the first step.

    Adding the same parent item again by entering its ISBN in the Add Item by Identifier tool, there are no automatic tags, as expected.
  • Thanks — this was happening when PDF metadata was retrieved by ISBN. Fixed for the next Zotero beta, which should be out in the next day or so.
  • Thanks for fixing this!
  • Fixed in Zotero 5.0.93, available now.
Sign In or Register to comment.