Unable to cite in Microsoft Word 2019

Report ID: 1583148940.

Recently updated to macOS Catalina v10.15.7 and Word for Mac to v16.41. The Zotero tab appears, but pressing any button gives an error: "Run-time error '5': Invalid procedure call or argument" -- the heading on this error is Visual Basic for Applications.

I've tried re-installing Word, re-installing Zotero, and the manual plugin installations for Word for Mac 2019, still the same error.
  • edited September 29, 2020
    We get a report for this once a year or so but have not found a way to fix it. Your best bet is to try to create a new user account on your Mac and see whether citing works there.
  • I have had this same problem recently as well
  • @ahubl101: Please start a new thread and explain the problem you're experiencing, along with details of your system.
  • Hello, I'm working with my IT (this is a work laptop), we created a new user on my Mac, but I still had the same error under the new account.

    My IT folks also wanted to know if Zotero is 64 or 32 bit, and also if this issue is mainly with Catalina (e.g. did it happen with Mohave?).

    Thank you for your help on this, not sure what I should try next.
  • edited 25 days ago
    Zotero is 64-bit (if it were 32-bit it wouldn't work on Catalina since it no longer supports 32-bit software). There are reports of this that go a number of macOS versions back.

    Note that this is an extremely rare issue and most likely a result of the way Word was installed, the way it is configured, or perhaps some security software or features on the computer. Reinstalling Word might help.
  • Hi, I worked with folks at IT to fully un-install Microsoft 2019 then re-installed it. Interestingly the Zotero tab wasn't in Microsoft Word this time, so I did the manual install (for Microsoft 2019) per the Zotero help page. The tab reappeared, but still got the same error.
Sign In or Register to comment.