Incomplete Sync

Hello,
I'm having difficulty completely syncing a group library to my Zotero account. When I access Zotero online, I see that there are the correct number of files loaded-- however, when I open Zotero on my desktop, there are 140 files that have not synced. I've tried clicking the green arrow on the top right corner, which spins for about 5 seconds and then stops, as if the syncing were completed. My other team members have successfully synced the full libraries on their desktop applications. Any suggestions for troubleshooting this problem?
Thank you!
  • Thank you for the link-- I had already tried those suggestions, but am still unable to fix the problem. Most of the items in the group library have successfully synced to my computer (~10,000 articles), except for 140 articles that are missing. It seems as though my Zotero account thinks that the sync is complete because it won't load these remaining items. Is there any way to fix this problem?
  • From that page:
    6) Further troubleshooting

    If you're still having trouble, post to the Zotero Forums with a Debug ID for the first sync after making a change that doesn't sync (e.g., making a change to the online library that doesn't appear in Zotero). Start debug output logging before making the change and keep it going until the sync has ended.
  • Here is my Debug ID: D1990196937

  • edited 20 days ago
    No items to upload in [group library]
    @glinfield: Did you make a change to an item in the online library before syncing, as the instructions above say?
  • There are about 10,000 articles in our group library, but I'm not sure which are the 140 articles that have not synced. I know that they have not synced because the numbers do not match online and in Zotero. Given this, I am not sure what type of change to make in the group library?
  • Any change to any item will do for this purpose as it should start a sync.
  • @glinfield: Sorry, I meant to say online library above, not local library.

    Click any item in the online library, and then replace the 8-character string in the URL with "VQQYYXA8" and load that. Based on your debug output, that should be an item that's not available locally, which you can confirm by pasting "VQQYYXA8" into the Zotero search bar in All Fields & Tags mode — nothing should show up.

    Make any change — e.g., editing the Extra field — to that item in the online library, and if you have auto-sync enabled Zotero should start syncing within a few seconds. Start debug output logging before you make the change so it captures that sync, and then submit it immediately after.
  • Ok, thank you-- I enabled debug output logging, made a change to that article, and then disabled the debug logging. Here is the debug ID I received:
    D1517122257
  • You don't appear to have made a change to that item. It was last modified two days ago. You have to edit the item itself, not a child item like a note.
  • @glinfield: Something definitely went wrong here, though — you do appear to be missing a lot of parent items locally.

    What was the exact process you followed to set this up? It looks like all items in this group were created a couple days ago. What happened on this computer after that? Was this computer online and syncing when the items were added on another computer?
  • Yes, most of the items were created a few days ago. On Monday, I believe my computer was online and syncing after the items had been added on another computer. But it is possible that some of the items were added while my computer was already online and syncing. My other team members haven't had any difficulties syncing, though.

    I just made a change to the item itself (to the Extra field) and here is the new Debug ID: D1466689713
  • OK, so that item should now exist locally after that sync.

    I'm not sure what happened here, and we'll see if we can reproduce this, but the easiest thing to do is just close Zotero, delete zotero.sqlite in your Zotero data directory, and restart Zotero and sync the empty database (Zotero will warn you — say yes) to pull down the library again in full.
  • Ok, thanks, I will try doing that now. Just to clarify, will this delete all the items from my Zotero and then re-download the full library? Or will it just load the missing articles?
  • zotero.sqlite is your Zotero database, so after deleting that and restarting Zotero it will be completely empty. But when you sync it'll just pull down all the data from the online library (and you're not deleting associated files, so it won't have to redownload those).

    This was likely some glitch where some item additions made while your Zotero was syncing were skipped. That's definitely not normal and not something you should worry about happening in the future, but we'll look into it and see if we can figure out why it happened here.
  • Sounds good-- I just have one more question. I'm trying to find my Zotero data directory. Per the instructions linked above, I went to Preferences --> Advanced --> Files and folders --> Show Data Directory --> and then opened a folder entitled "Zotero" which contains many files. One of them is called zotero.sqlite, but there is also zotero.sqlite.1.bak, zotero.sqlite.bak, and zotero.sqlite-journal. I should only delete zotero.sqlite, correct?

  • Great, thanks for all your help!
Sign In or Register to comment.