Word keeps freezing when trying to add citation

Hi, I use Zotero on my macbook air 13'' 2015 and so far it's been great and I haven't experienced any bugs. However, today I wanted to add a citation in a document which already has citations from Zotero and word kept freezing.

I tried opening a new word document and adding citations, which made microsoft word freezing again. Every time, I had to force quit microsoft word because the whole screen was just lagging and I could not use any other button in word. I have Zotero 5.0.88.

Can somebody help please :(
  • Did you try restarting Zotero? Your computer?
  • Yes I even deleted and reinstalled Zotero. I did restart my computer too...
  • Could you submit a Report ID?
  • I tried to reproduce the steps leading to the lagging and then tried to report the errors, but Zotero says that it did not detect any errors. So I guess the problem comes from microsoft word. However, word only freezes when I try to do anything related to Zotero. I will try to send the error report from microsoft to their tech team to see if they can help.
  • This is almost certainly a Zotero issue. Anyone can reproduce this if Zotero process is killed instead of closed normally, however restarting Zotero should fix it. Please submit a Report ID as described above.
  • Although if there are no Zotero errors to report, then please submit a startup Debug ID from Zotero instead.
  • Hi, the debug ID is : D460948201
  • Any chance you are running Zotero from the downloaded image? Did you move Zotero into Applications? If you go into Preferences -> Cite is there an option to (re)install the Word plugin?
  • When I run Zotero, I open it from the application folder directly to avoid running it from the downloaded image. Also, when I go into Preferences -> cite, I can see the citing styles and the word processing (not quite sure of the english term since my zotero is in french) buttons. In the word processing page, I only have one option which is called : Use classic window to add citation (again not the exact option name since it’s in french). It is enabled.
  • Is it possible you've previously opened Zotero from a disk image?

    If you close Zotero, go to your Zotero profile directory, move extensions.json to your desktop, and then restart Zotero, does it work then?

    If so, can you email the old extensions.json file to support@zotero.org with a link to this thread?
  • Hi it did work. I sent the file to the support team with a link to this thread. Thanks a lot!
    Is there anything else I need to do or will zotero be working normally from now on?
  • /Users/[…]/Desktop/Zotero.app
    Yeah, so you previously had Zotero on your Desktop rather than in Applications — that's what caused this. You should delete all copies of the Zotero app other than the one in Applications, and only run it (and any other program) from there.
  • All right, will do from now on! Thank you for your time and patience. I really appreciate it!
Sign In or Register to comment.