Report ID 858266127

Hi,

I'm working on a google doc with many Zotero citations. The doc was functioning before for adding citations and updates, but I started getting the error modal (with link to the troubleshooting page) after trying to add new citations recently.

After troubleshooting (making a copy of the google doc with the zotero citations, doing binary search, looking for problem citations by doing a binary search, generating the error report/logs, updated Zotero), I discovered it was an account error, and got the duplicate document to update after switching.

However, on returning to the original google document to add citations, a new error started showing up (in this report, and along with the original error modal); and I am wondering if maybe it has something to do referencing the citations to the original document object in the application...

Could you please help me look into this? It is a large document and we have put a lot of effort into it so far, and hope to complete it soon.

Thank you,
  • If you restart your browser and Zotero, and try again in the original document, do you still get an error?
  • Hi, Thanks for the fast response! Unfortunately yes, the error modal still shows up if I try to refresh Zotero or add a new citation. The error log changed though (submitted report id 1420493716)..
  • OK, @adomasven will need to take a look. Might not make a difference, but in the meantime you could try in Firefox just to see if it happens there too.
  • edited 19 days ago
    @will.chang: Actually, you should first try with all other extensions disabled.
  • edited 19 days ago
    Hi, Unfortunately the same issue, I tried disabling all other extensions and restarting Zotero and Chrome. The error log is same as before:missing Javascript object properties and extension access issues. I made sure to use the same accounts for docs, zotero, and the extension and reauthorized my credentials.
  • Could you produce a Debug ID from Zotero and the Zotero Connector? You should enable debug logging on both first, then perform whatever action causes the error (and click through any dialogs) and finally submit the two debug IDs from Zotero and the Connector.
  • edited 18 days ago
    Hi, Thank you for following up on this. Here are two separate sets of debug ids/logs from my account:

    Set #1:
    Connector: Debug ID 1326398489
    Desktop: D801038441
    Action: Hit "Refresh" Zotero in google doc file menu under "Zotero" tab, error modal pops up to load the Zotero debug troubleshooting page

    Set #2:
    Connector: D1946763949
    Desktop: D1847493859
    Action: Hit "Z" button to add/edit Zotero citation in the google doc toolbar, select a citation from the red Desktop app searchbar, hit enter, error modal pops up to load the Zotero debug troubleshooting page

    Let me know if I can provide anything else,
  • So you're hitting some really bizzare errors that might indicate that the doc is corrupted on the Google Docs end. This is really rare and I believe I've only seen it happen once before your report. Are you sure it doesn't work in a copy of the document either? Can you produce a Debug ID from Zotero (Connector not neccessary) in a copy? Could you attempt the binary search on a copy of the document? First step being removing the whole document and seeing if the error is still present (since it might be the case given the strangeness of the error).
  • Interesting...

    I did try duplicating the original document again after resetting all my authorizations and logins, restarting, and everything works now! This new duplicate/copy ported all the Zotero links from the original document and I could refresh Zotero and add new linked citations.

    What do you think might have corrupted it?

    I think we'll just create a new/fresh copy to work from for now.

    Let me know if you would still like debug logs from somewhere, and thank you for your help!
  • I don't know if Google Docs itself is fully bug-free, especially when multiple collaborators edit, or when using less common features, so it could have just "got corrupted". If you've used other Google Docs plugins, they could have had an impact. Even Zotero itself failing to update the document for some reasons could cause corruption. Either way, glad it works now.
Sign In or Register to comment.