Microsoft Word Scrolling Issue

I'm having an issue where after inserting a citation into Microsoft Word (ver. 16 on MacOS) from Zotero, trying to scroll in the document keeps jumping me back to the top of the document. I turned off automatic refreshing of the citations, but the issue persists. This is a moderately long document with 100+ footnotes over 30 pages.

After several minutes of trying to jump back to my position, it eventually stops and I can resume typing until I try to enter the next citation.

Is it possible that despite turning off auto refreshing (which I turned off midway through the project), that some of the citations are still refreshing causing this behavior?

I think it is similar to this old thread, which had no good resolution. https://forums.zotero.org/discussion/73719/jumping-up-10-pages-whenever-put-a-citation-in-in-word-10.

  • It is not recommended to edit the document in any way while Zotero is updating it as that could potentially lead to citation corruption. Unfortunately citation edits and insertions in Mac Word will sometimes cause cursor jumping, which is unpreventable. However if you have disabled automatic updates and with a document of such moderate length it shouldn't be taking more than a few seconds. What version of OS and what specific Word version are you on?
  • I'm running macOS Catalina 10.15.4, and I'm running Word 16.38. Does the selected citation style have any impact at all on the cursor jumping issue?
  • You will see more jumping with note styles than in-text ones, but even with in-text ones it will happen for any inserts that require text with non-standard latin characters.
  • I have simliar problem with microsoft system. When I add a citatation, what I can see of the document moves up to the beginnig of the document and it is difficult for me to find the part I have just edited.
  • How long is your document and did this used to happen before? Does the cursor jump back to its original position if you wait for the insertion to finish? What citation style are you using? What is the specific version of Word that you are running?
  • It started to happen some months ago. It happens immediately. I use word2 2016, and for the moment I use Human Relations citation style.

  • and I should add that it does not happen all the time. I cannot really figure out a logic though.
  • As per above, it happens when you insert a citation that has non-standard latin characters: any characters with diacritics or non-latin characters. You can check your Word version by right-clicking "Microsoft Word.app" in Applications and selecting "Get Info".
    It happens immediately.
    What happens immediately? The citation is inserted immediately and the cursor ends up at the start of the document? You do not perform any actions in Word while Zotero is formatting the citation, right?
  • As far as I know I am not using many citations with non-standard latin characters. There are a few names where the author's name has a diacritical, and no non-latin characters.

    And to be clear, as far as I can tell, the insertion point isn't moving. What happens is the visible part of the document changes. In my experience the issue is triggered by scrolling the page, not adding the citation itself.

    In greater detail, here is the experience I have:
    1) Insert citation (I'm using footnote, not endnote style), so the footnote is often just outside of the visible view.
    2) scroll down the page slightly, to where the footnote is just visible
    3) document view jumps up to the top of the document
    4) scroll back down to the insertion point, and while scrolling the document jumps back up to the start
    (repeat over and over until somehow it resolves it self after a few minutes)
  • @budish Do you see the jumping in a new document? How severe is it there? How long does it take for things to settle down?

    If you insert 2 citations one after the other on your existing document, do you see a lot of jumping for the second insert, and does it also take minutes? Even if you have automatic citation updates disabled?
    As far as I know I am not using many citations with non-standard latin characters. There are a few names where the author's name has a diacritical, and no non-latin characters.
    On a second thought the jumping will also happen if you use a citation style where the inserted citations have any rich-text styling: italics, bold, etc.
  • "On a second thought the jumping will also happen if you use a citation style where the inserted citations have any rich-text styling: italics, bold, etc."

    That must be it - I was using the bluebooking style, which definitely includes styling. So if I change the style back to say Chicago, that should in theory fix the issue?

    Do I need to update the citations before I switch styles or can I switch styles even if my document has a bunch of unupdated citations?
  • You can switch styles with unupdated citations, Zotero will update all of them upon switching.
Sign In or Register to comment.