Minor issue: scrolling bar covering the (+) button to add authors (5.0.86 / MacOS 10.15.4)

Hello everyone,
This is a rather small but annoying bug. On Zotero (5.0.86, MacOS 10.15.4), the Info pane displays a scrolling bar on the right of the pane. Unfortunately, when activated, it covers partially the plus (+) button to add an author, which makes clicking on it a bit more difficult.
Would there be a way to fix this? Or maybe signal it to the developers?

Thanks for your suggestions,

  • Developers read every thread, so posting here is the thing to do.

    This doesn't happen normally. Can you take a screenshot that shows this happening for you, upload it somewhere (e.g., Dropbox), and provide a link here?
  • That URL isn't public.
  • Sorry, doing several things at the same time is rarely the most efficient way.
  • Does this happen for any item in any collection? If you toggle in and out of Stacked view, or resize the panes or window, does it still happen?
  • edited May 11, 2020
    Basically, this doesn't happen normally, and I can't reproduce it even on macOS in Stacked view and the French locale, so it's something specific to your installation and you may need to experiment with various things in the interface to figure out what causes it.
  • It happens for all items. The problem disappears with standard display, but the only reason for this is that the pane is then long enough to accommodate all the lines and so does not require a scrolling bar.
    Resizing the bottom pane is another way around the issue, but it does not solve the question.
  • The problem disappears with standard display, but the only reason for this is that the pane is then long enough to accommodate all the lines and so does not require a scrolling bar.
    Have you tested that? If you shrink the window vertically, does it happen in Standard mode too?
  • (Again, this isn't a general problem. The scrollbar does not overlap the buttons normally.)
  • I may not help troubleshoot this, but I thought this just happened with hidden scroll bars, especially when they enlarged, covering the plus keys. It happens in the center pane, too (and not only with Zotero, but everything with hidden scroll bars in Mac OS). When the scroll bar is back to its thinner self, the problem is less pronounced. And even with the thicker scroll bar, if I can aim well, I can hit the + sign. A bit of an annoyance, but just that.




    I see this on my MacBook Pro running MacOS 10.13.6. Scroll bar only appears when I touch my touchpad, and then furrther maximizes if I hover over the scroll bar.

    On a Mac mini running 10.14.6, the scroll bar is not hidden, and does not grow in size, and there is no overlap.
  • Problem on my OS 10.13.6 MBP is solved if I set the value of "Show scroll bars" under System Prefeerences -> General to the non-default "Always". Then, Zotero immediately moves away the + sign and opens up space for the scroll bar.

    Of course, you may not want to do that.
  • edited May 12, 2020
    Oh, yeah, Anael, is that what you mean? That's just a stupid setting in macOS to try to make the macOS more like iOS, despite totally different constraints. Those scrollbars will overlap anything close to the edge in any program. We almost certainly can't detect when that mode is enabled, and even if we could, moving the content away from the edge to make space for the hidden scrollbar would defeat the entire purpose of its being hidden to begin with.

    I'd strongly recommend just setting this to Always. (Overlapping aside, when hidden there's a real cost in usability of not being able to always see your current scroll state.)
  • (@enozkan: Thanks for figuring this one out.)
  • Indeed, this is exactly that, and setting the scroll bar option to "always" works perfectly.
    A thousand thanks to @dstillman and @enozkan for your help.
Sign In or Register to comment.