Can't open my library

This discussion was created from comments split from: Cannot sync with - Error message.
  • I can't open my library in Zotero today and am freaking out with a deadline for tomorrow! IS the system down??w
  • Are you referring to the Zotero program or to the web library on this site?

    If you're referring to the latter, there's currently some slowness that we're looking into, but you should be able to access your library if you reload a few times and wait for it to load.
  • Could you say exactly what's happening? You're trying to do what exactly where and seeing what sort of error message/behavior?

    Nothing Zotero-related is down, FWIW.
  • It was the library on the site (My library).
    Now I managed to open it but can't import my bibliographic list from CINAHL Plus database - when I press the icon to save to Zotero there's a message to check the "translator", and I have no clue what that means.
    I'm using a chromebook so it's the zotero connector version
  • Just managed to figure it out - it was just too many articles selected at once (146)
    I tried selecting only 10 articles and it worked
    Thanks everyone!
Sign In or Register to comment.