Allow opening file?

I just installed Zotero from the default apt repository on a clean Ubuntu 20.04 install. I'm getting the "Allow opening file?" dialog each time I'm opening a linked .pdf file to any of my library entries.
Does anyone know how to fix this? It's really annoying.

  • What's the full text of the dialog?

    Are you using a Zotero snap? (Does 20.04 support snaps by default, or something like that?)

    We don't provide an official package beyond the tarball on this site, and some community members offer packages, including and
  • Yes, this is the snap package from - I think that's the new default package manager for Ubuntu 20.04.

    The full text is like this
    Allow opening file?

    Allow snap "zotero-snap" to open file "/home/martin/Gdrive/Zotero/pdf_title.pdf"?

    This dialogue will close automatically after 5 minutes of inactivity.

    I'll try to remove the snap package and install the official tarball and get back with the result.

  • I can confirm that the official tarball installation does not suffer from the issue.
  • @extraymond, the maintainer of the Snap, may have a suggestion.
  • I had the same issue; I was using `zotero-snap`, and found that it kept bringing up this dialog.

    I tried editing `~/.local/share/applications/defaults.list`, but to no avail.

    When I tried to explore `/usr/bin` from Zotero's `Preferences > General > Open PDFs using > Custom ...`, I noticed that I could *not* see `/usr`, nor certain binaries in `/usr/bin` (e.g. default-installed `/usr/bin/evince`).

    I called `sudo snap remove zotero-snap` - which unfortunately removed all of my user data too :( - and then installed the `*.tar.gz`, and did not have an issue with the "Open With" dialog; I could also see `/usr` from Zotero itself.

    My guess is that it's something to do with how `snapd` (re)mounts certain directories?
Sign In or Register to comment.