Empty citation dialog after clicking Add/Edit Citation on an existing citation

This discussion was created from comments split from: Bug in Citations in Word.
  • edited April 22, 2020
    I have a graduate student who seems to be experiencing a similar issue. She's working with Word for Mac v16.36 and Zotero v5.0.85 and did the following:

    -Opened a Word document she was working on previously
    -Selected an existing in-text citation citing multiple sources
    -Clicked on 'Add/Edit Citation' to add another citation to it
    -When the mini Zotero search bar popped up, it was completely blank
    -Re-added the citations and *then* included the additional citation

    Apparently, she's had to do this with each in-text citation. I had her try the cut/paste-into-a-new-document method and it worked *at first.* She was able to click on an existing in-text citation, select 'Add/Edit Citation,' and see what she had cited in the mini Zotero search bar but when she tried it a second time the mini Zotero search bar was blank again. She reported that this happened a number of times with a variety of her in-text citations.

    I'm not sure what additional info you'll need to help diagnose the problem. Should I have her save her entire Word file as a new file and try again? Or uninstall and reinstall Zotero?
  • @melray -- no, that's different and in contrast to the above, this one is clearly a Zotero issue. Also sounds vaguely familiar.

    @dstillman -- could you please split this off? Also, do you recall where this has come up before and if so what the solution was?
  • There've been a couple reports of this, though we've haven't been able to reproduce it ourselves. @melray, we might have additional questions, but the best thing to suggest at the moment is restarting the computer, which has fixed it for other users, at least temporarily.
  • @adamsmith, @dstillman, thanks for the new discussion thread!

    The student reported that when she first encountered the problem (yesterday morning), she restarted both apps (Word and Zotero), and then restarted her computer in an attempt to fix it but that didn't work. She was also able to recreate the problem for me (via Zoom screen share) yesterday afternoon.
  • Does this happen only in an existing document, or can she get it to happen in a completely new document with a single citation?

    Could you ask her to generate a Debug ID for reproducing it and post it here?
  • edited April 27, 2020
    @dstillman, apparently the issue hasn't happened since I reported it. The student is still working on the paper and will let us know when/if she encounters the problem again.
  • @dstillman - this has happened repeatedly for me too, in multiple documents. When I place my cursor within the grey-ed out citation and click add/edit citation, the zotero window that opens is blank. I'm using word for mac v 16.36 and zotero v 5.0.85. Let me know if you have any other tips as you investigate!
  • @kfritton: If you can reproduce this reliably, it'd be great if you could temporarily install the Zotero beta and generate a Debug ID from that for this happening.
Sign In or Register to comment.