Unable to communicate with Zotero server

Hello everyone,

I'm getting this message from two different machines, in two different networks (both rebooted and etc):

Unable to communicate with Zotero server. Please check your connection. Cannot read property 'sortKey' of undefined.

This is hampering the upload of new documents and the creation of new entries. The only way I can upload things is through DOIs, but this document in particular, has none.

Any ideas?

Thanks in advance
  • Could you describe what exactly you're doing and where when you get this message? Is this on the website or in the software?

    If the software, check database integrity from the advanced tab of the preferences, then provide a debug ID covering whatever operation triggers this error: https://www.zotero.org/support/debug_output#debug_output_logging
  • Sure, thanks for your quick reply by the way.

    We're using on the website. We tried to add a journal article or upload a file by clicking on the `+` icon, on the top right of the web library.

    After many minutes my attempts were converted in actual additions/entries. But when I clicked, I got that aforementioned error message.

    Is this anyhow important to be reported or it was just the server being busy?

  • Is this still happening on does it work normally now?
    (Posting here is all the reporting that is needed; developers read all posts)
  • I'm having the same error message, but the entry is created anyways.

    Here's a print showing an empty entry recently created and the error message being displayed on a dialog: https://i.imgur.com/yVl63K7.png

    So, for me, it's working (I'm able to get the entry in) but I probably shouldn't be getting that error message, right?
  • edited April 22, 2020
    I suspect your local storage somehow got corrupted. I'm going to investigate how this is possible, however as a quick fix you can try to reset it. To do this go to web library, open browser console (for example by pressing Cmd+Option+i on macOS) and type the following command:


    Press enter to execute the command and reload the page. Please let me know if this helps.

    (this will reset your columns, including which columns are visible, order etc.)
Sign In or Register to comment.