Word plug-in switching into All Markup when adding or editing citations

I've been trying to just ignore and get on with my work in the face of this annoying problem, but it's now driving me up the wall.

I am mostly working in Tracked Changes of a word document, but prefer Simple Markup view most of the time. When I add or edit a citation with the Zotero plug-in, the document automatically switches into All Markup which results in the display showing a different part of the paper to the bit I'm actually adding or editing a citation to (due to there being many changes in the document and making it considerably longer when in All Markup mode). Then I have to scroll through to find my spot again and/or manually switch back into Simple Markup.

Is there any way to stop Word from switching into All Markup? I'm using Office 365, so it should be the latest version... Had a look at some older posts, but didn't find anything particularly helpful other than to tell word not to show insertions and deletions when in All Markup. I'd rather not do this though because I do actually switch into All Markup every so often and want to see the insertions and deletions, and I don't want to have to deal with the extra step of toggling the options of what should be shown when I do this.

thanks!
  • I am also seeking a solution to this problem. At first it was a minor annoyance, but as I'm getting stuck into formulating and writing my ideas for my thesis I'm really being taken out of my frame of mind and losing my train of thought.
  • When Zotero inserts citations it needs to be in no markup mode and after that Zotero turns markup back on if it was enabled before the insertion. Problem is Simple Markup has been added in a relatively recent version of Word and there is no API to choose between All Markup and Simple Markup, so unfortunately that's the behaviour Zotero has and currently there's nothing we can do about it.
  • Bummer. Well, I hope they'll take notice of this and hopefully change it soon. I'm finding it very distracting.
Sign In or Register to comment.