How exactly to install Zotero on Chromebook

For context: I'm brand new to using Linux on my Chromebook (I'm using it just so I can get Zotero), so I'm looking for clear step-by-step directions.

Here's what I've done, followed by where I'm stuck:
-I've downloaded the Zotero tarball
-I moved it to "Linux files" on my "Files" app
-Using the Terminal, I extracted the contents using this command: "tar xvjf Zotero-5.0.85_linux-x86_64.tar.bz2"
-I moved to the new directory it created using this command: "cd Zotero_linux-x86_64"

And this is where I'm stuck:
The installation instructions (at say: "Download the tarball, extract the contents and run zotero from that directory to start Zotero." How exactly do I "run zotero" (i.e. what do I need to type into the command prompt)?
-->I tried "bash zotero" And it returned: "XPCOMGlueLoad error for file /home/[my username]/Zotero_linux-x86_64/ cannot open shared object file: No such file or directory
Couldn't load XPCOM."

Am I missing a file? If so, how do I get it?

Also, would it be possible for to simply offer a .deb file for installation rather than downloading the tarball? It sounds like that makes it much easier to install on Chromebook.

Thanks for your consideration, and for your help with this question!
  • There's an (unofficial but highly trustworthy) deb here: including instructions for installation on Chromebooks (note that Zotero doesn't run on ARM processors, increasingly common for Chromebooks, though)
  • Thanks for your help adamsmith! However, I'm trying to do this directly through rather than do appreciate that possibility, but I'm a little paranoid about downloading and installing software from sites like github. If there is any way I can do it with the tarball, that'd be appreciated.
  • Certainly understand your caution, but do note that Emiliano (@retorque on GitHub; @emilianoeheyns here) is one of the most active Zotero plugin developers, so he is a trustworthy source.
  • My scripts are simple and open source, and as far as I can tell they could be ran as-is (after inspection I'd assume) by the official zotero build & release process. I'd release my work under any license deemed convenient to zotero. But until that happens, I'm happy to keep providing the debs.
  • Also, while I can't offer a checksum that I couldn't also manipulate, the debs simply install the official binaries. If you ran a checksum between the binaries of the tarball and the Deb-installed binaries, there will be no differences.
  • Before we go any further, could you run
    uname -m
    in your terminal? That'd tell you your processor architecture. Given the error above, I think there's a fair chance you're on ARM and don't need to look further.
  • Thanks to all of you for your help! I'm sorry, I didn't mean to impugn anyone; I didn't realize that a Zotero developer was the one who had actually created that Github. I went ahead and installed it from Github and it's working well.
  • I'm not a Zotero developer though. I repackage the official binaries, but I am not officially affiliated with Zotero.
  • A bit too late, but I just went through the process myself. The error message just says that a bunch of dependant libs are missing. This worked for me:

    sudo apt install libxt6 libdbus-glib-1-2 libx11-xcb1
  • That's a large part of the benefit of my debs - they pull in these dependencies automatically
Sign In or Register to comment.