Edit citations not found

When I go to edit citations that I have already inserted, they do not come up in the Zotero bubble. It means if I want to insert an extra citation, I have to delete all of the references and re-insert them.

Attached is the reportID: 192201439
  • When I toggle field codes, they are still there
  • Can you provide a Debug ID for clicking in a citation and clicking Add/Edit Citation and getting an empty citation dialog?

    Does this work with a new citation in a new document?
  • D1985209136

    Same issue with new documents
  • What Word version?

    You're saying if you start a new document, insert a new citation in APA style, click in it, and click Add/Edit Citation, you get the red bar citation dialog with nothing in it? What does it show in the document at that point?
  • word 16.35

    If I start a new document I can insert a new reference. But if I click that reference and try and edit it, the reference that I just added doesn't appear in the red bar citation dialog
  • Forgot to mention it is on Mac as well
  • And what exactly does it show in the document itself while the citation dialog is open?

    Are you using a customized Normal.dotm by any chance?

    If you reinstall the Word plugin from the Cite → Word Processors pane of the Zotero preferences and then restart Word, and also restart Zotero, does it still happen?
  • No I am not using a customised .dotm

    When the citation dialog is open, the citation that I've selected is grey.

    I've done the reinstall twice and still happens
  • Do you have any idea what changed on your system between the last time you worked on this document with Zotero? Any system or word updates?

    Does it work in a new document after you restart Zotero? Does insertion work fine? Could you temporarily create a new User Account on your Mac and see if Zotero citation functions properly there?
  • This function has never worked since I installed Zotero.

    Insertion works fine. It is only when i try and edit a citation that is already inserted. Would there be an issue with my library as I imported it from endnote?
  • Having imported from Endnote is very unlikely to affect this. Could you install the Zotero Beta and generate another Debug ID for an edit which does not show cited items in the citation dialog? Could you try testing in a new user account on your Mac?
  • Here is the Debug ID D921876216

    For you information, I did the edit function three times. The second time the citations were shown in the citation dialog. The first and third one it did not work
  • I created a new user account and it worked in that account as much as I could tell
  • Okay, so I feel like I have resolved it but we will see if this is the case in the long term.

    I removed all track changes. None of the track changes were in the references but that still seemed to have helped.

    I am also using a dual screen. When I moved zotero into the same screen as word, that appeared to resolve the issue.

    Hopefully I won't contribute to this thread in the future.
Sign In or Register to comment.