Issues with UI on windows HiDPI display

I am using zotero 5.0.84 and spotted some UI display issues.

The first one is plus/minus button in Preferences/Advanced/Feeds. The buttons are too small to be clicked. See the image for clarification: https://imgur.com/a/WT6dUO5

Another one is dialog when emptying trash. The buttons of OK and cancel were cut off. See the image: https://imgur.com/a/LzkCrNN

OS: windows 1909
Resolution: 3840x2160
Zotero: 5.0.84
  • See the first issue but not the second on the same OS/resolution in Zotero 5.0.85-beta.10+8cd04e5d9
  • Thanks. I am new here and have no idea about finding the issue you mentioned. But I've tried Zotero-5.0.85-beta.13+c26ffedf9 and the problem still exists.
  • edited 11 days ago
    (I’m a regular volunteer here. I was just confirming that I could replicate your issue and giving some more information to the Zotero developers.)
  • edited 11 days ago
    Many thanks for your help. The second issue is also reproduced in the latest beta version at my hand.
  • I can reproduce the second issue. This should be a display scaling issue that goes away if you set Windows 10's "Change the size of text, apps, and other items" to 100%. It appears when setting this to something larger, e.g., 300%. I noticed a possibly related issue for BBT's preference window, see here. The BBT issue started with Zotero's switch to Fx60, see here.
  • I've followed your advice and tried several display scaling. Only the setting above 200% can reproduce the problem. I am currently using the default 250%.
  • I found a fix that works for me. You can preserve your Windows system settings for display scaling while changing the scaling for Zotero. In Zotero's Config Editor, the preference layout.css.devPixelsPerPx is set to -1 by default. Change this, e.g., to 2 for a scaling of 200%, as explained here. (Note: Don't change this in Firefox, but in Zotero, which is based on Firefox.)

    The BBT issue mentioned above appeared for me with a system display scaling of 150%. This is fixed for me with the Zotero preference layout.css.devPixelsPerPx set to 1.4.
  • I tried your fix but it doesn't work for me. The value only changes the text scaling but nothing.
  • I haven't checked for your first issue. But at least the second issue should be fixed by reducing the display scaling.

    Setting layout.css.devPixelsPerPx to 2 should fix your second issue if a system scaling of 200% fixed it. From my tests, the layout preference does the same as the system scaling settings. The advantage would be that you could keep your system scaling at 250%. In Zotero, you could adapt the Font Size settings in the View menu, if needed.

    If this is not the case, make sure that you're not using the settings marked with green arrows here: https://superuser.com/a/954582.

    You could also try this:
    1. Find "zotero.exe" in your "Programs Files (x86)" folder.
    2. Right click -> "Properties"
    3. Go to "Compatibility" tab.
    4. Check "Override high DPI scaling behavior".
    5. Choose "Scaling performed by:" -> "Application"
  • Thanks for your tips. I've set the value to 2 and the second issue is fixed. One disadvantage is that the icons and menus are a little small now. It is acceptable now but still requires a fix to solve the problem.
  • When using layout.css.devPixelsPerPx with multi-monitor setups, one should keep in mind that the scaling will not adapt to the monitor. (There was a Firefox add-on for this purpose: https://github.com/ertug/autohidpi.)

    It's possible that these display scaling issues are specific to the underlying Firefox version currently used in Zotero. The Zotero developers are planning to move from Firefox to Electron/Chromium, see here. So the situation should be different at the latest when this migration happens.
  • Thanks for clarification.

    I also noticed another problem when setting the value of layout.css.devPixelsPerPx to 2. It does solve the clip of Empty Trash (second issue here) but the clip of Delete Collection appears (there is no problem with the default setting) https://imgur.com/a/UbBbY60

Sign In or Register to comment.