OpenOffice Writer: Zotero-Verweis zerstört Formatierung / Zotero reference destroys formatting

Ich arbeite erst seit Kurzem mit Zotero. Ich arbeite mit OpenOffice Writer. Immer, wenn ich mithilfe von Zotero einen Verweis in den Text einfüge, wird die Formatierung des jeweiligen Absatzes zerstört. Plötzlich ist der Zeilenabstand nicht mehr wie zuvor 1,5, sondern 1,0. Außerdem ist plötzlich eine Fettschrift da, wo keine sein soll. Auch das Literaturverzeichnis wird immer in Fettschrift angezeigt, obwohl ich das nicht so haben möchte. Wenn ich all das manuell korrigiere, ist es nach dem Einfügen des nächsten Verweises wieder genau so falsch. Hat jemand hier einen Hinweis?

I just started working with Zotero. I work with OpenOffice Writer. Whenever I use Zotero to insert a reference into the text, the formatting of the paragraph is destroyed. Suddenly the line spacing is no longer 1.5, but 1.0, and boldface is suddenly where it shouldn't be. Also the bibliography is always shown in bold, although I don't want it to be like that. If I correct all this manually, it will be just as wrong again after inserting the next reference. Does anyone here have an advice?
  • edited February 10, 2020
    We don't support OpenOffice and haven't in many years. You'll need to use LibreOffice, which is much more actively maintained.
  • Although I believe Zotero will apply the Normal (or Standard or whatever it is called) LibreOffice style to a paragraph in which you insert a reference, so you can prevent unwanted changes by adjusting that style.
  • Thank you for your comments! I will try it with LibreOffice.
  • I use Libre Office and have a similar issue where I have a double-spaced document and when I insert a Zotero reference it collapses my paragraph to single-spaced. Is there a setting I could adjust within Zotero so it keeps my chosen spacing?
  • My problem is unfortunately not solved in LibreOffice either.
    My default setting in LibreOffice is: font size 12, font "Liberation Serif", no bold font. This is the setting when I create a new text document.
    But when I insert a Zotero reference to a citation block in a text document, the following happens to the whole section:
    - The font size becomes 13.
    - The font formatting becomes bold.
    - The line spacing is no longer set to 1.5 (manual setting), but 1.0.
    - The (manually set) indentation of the paragraph by 1 cm has disappeared.
    - And: The bibliography is completely in bold.
    I have not yet found a way to prevent a Zotero reference from destroying all formatting.

    Mein Problem ist leider auch in LibreOffice nicht gelöst.
    Meine Standardeinstellung in LibreOffice ist: Schriftgröße 12, Schrift "Liberation Serif", keine Fettschrift. So ist die Einstellung, wenn ich ein neues Textdokument erstelle.
    Wenn ich aber in einem Textdokument zu einem Zitat-Block einen Zotero-Verweis einfüge, passiert mit dem ganzen Abschnitt Folgendes:
    - Die Schriftgröße wird 13.
    - Die Schriftformatierung wird zu Fettschrift.
    - Der Zeilenabstand ist nicht mehr wie zuvor (manuell) eingestellt 1,5, sondern 1,0.
    - Die (manuell eingestellte) Einrückung des Absatzes um 1 cm ist verschwunden.
    - Und: Das Literaturverzeichnis ist komplett in Fettschrift.
    Ich habe noch keinen Weg gefunden, zu verhindern, dass ein Zotero-Verweis mir die ganze Formatierung zerstört.
  • I had that same problem with LibreOffice a few hours ago, the resetting/changing of the whole paragraph was so annoying!

    Then I searched for an answer and the advice of "adamsmith" in this thread really worked. It's not about just changing the format of the page while writing it in text, you have to make the changes in the "FORMATVORLAGE" or style sheet (F11 in LibreOffice) and apply that to the whole document. Changing the text style, font size via the top SYMBOL-BAR and marking the writen text won't work with the whole document and therefore not with the Zotero Citation Tool. You can create an own FORMATVORLAGE or change the STANDAD as you wish. like spacing 1,5 and font size 12.

    Hope this works for you as well.
Sign In or Register to comment.