Zotero Connector has crashed, cannot open Google chrome

ID 2144047617
Debug D481146026

I have restarted computer repeatedly after uninstalling both chrome and Zotero and reinstalling both. However, every time I attempt to open Google Chrome I get and error message "Zotero connector has crashed, click this balloon to reload extension" . Upon clicking balloon, get caught in a loop where message keeps reappearing. Furthermore, the Zotero connection tab on top of Chrome tool bar (next to Google Scholar button) is missing.
  • That would be a problem with your Chrome installation, not the Zotero Connector. See No Toolbar Button.
  • I am experiencing the same problem. When I got back from a three week vacation, I was unable to open the chrome browser at all. The dialogue box is the same about the zotero extension. I uninstalled both zotero and chrome, then reinstalled chrome but still get the error message.

    Wife is not happy, as she watches Netflix on chrome and I can't get the application to run. Curious if dgjohns2 found a solution or if I have to find a reset point.
  • See the page I linked to.
  • Thanks, dstillman. I wish I could say that works, but it doesn't. I'm doing a factory reset.
  • Did you reset Chrome, as it recommends there?
  • Yes, I reset Chrome and followed the information on the link you provided, but it did not work. I did a factory reset on my machine and now chrome is working. Previously, chrome would not load at all, let alone show the zotero icon. Appreciate you trying to help. Thanks
  • I have not tried factory reset, but all other options suggested did not work for me either. Sadly, looks like I will have to do factory reset if I want to use chrome, or I will continue to use Microsoft edge.
  • Are the issues here all for Windows 10 version 1903 or 1909?

    If so, they are likely the same issue as this one:
  • As explained here, one workaround would be to run chrome with Code Integrity disabled: chrome.exe --disable-features=RendererCodeIntegrity. For other options, see the thread linked to in the previous post.
Sign In or Register to comment.