Scannable cite...

edited January 1, 2020
... doesn't show for me. I had to reinstall Zotero on a new system. Installing the ODF-scan I thought would now automatically install scannable cite.js. It did not. So I downloaded it manually, put it in the translators folder translators in the Zotero data directory. I then opened Zotero as I was watching that folder. Initially the translator file is there in the list, but as soon as I open the Preferences to select it, it disappears. It's as though it does a reset translators. Any solution to this? (Crashing to finish a paper before tomorrow evening, so in a rush...) Thanks
  • The Scannable Cite export translator is bundled with Jurism, which may be why it works there. I haven't tested for Zotero install behavior lately. Possibly only bundled translators are recognized? I'll try to take a look a bit later.
  • I'm not sure what's going on with the side-load of the Scannable Cite translator by the plugin. Zotero does log an error when loading the plugin, but I'm not sure it's relevant (I'll post separately to zotero-dev to follow that up). After a further restart of the client, though, the Scannable Cite translator does appear. Does stopping and restarting Zotero (with the plugin installed and active) once or twice have that effect for you?
  • I've succesfully installed RTF/ODF Scan and Libreoffice Zotero plugin, but when I try to configure Quick Copy under Preferences > Export >Default Format, I can't find "Scannable cite" in the list.

    I found the "Scannable Cite.js" file online and tried to manually install it in Zotero/translators folder. I could see how It was removed automatically from the folder after a while. Strange!
  • Frank - thanks. I'm not at home right now, but as soon as I will be I'll try again. But I do seem to recall that I tried this at least 3-4 times.But my experience was exactly the same as the past poster's...
  • I have been restarting Zotero, uninstalling, innstalling plug in again... still same issue.
  • Same here still too... It would really be great if somebody could find solution. Could somebody provide a link to a scannable cite.js that is NOT from Jurism and might be accepted?
  • Join the group... "scannable cite" doesn't show. Thank
  • Frank? Sebastian? Please?
  • The source of the Scannable Cite.js doesn't matter -- once downloaded, there's no way for Zotero to tell where a translator file comes from. Frank was wondering whether only "official" translators work with Zotero, but that's not the case -- otherwise, developing & testing new translators, which we do all the time, would be impossible.

    We currently have only two reports of Scannable Cite actively disappearing after manual download (and several others where it doesn't), and it works for us -- difficult to fix anything we can't reproduce.

    (ariek hadn't been able to download the file when they posted here, so not necessarily the same issue).
  • edited January 15, 2020
    adamsmith, thanks.

    Can you please prepare an "official" page with detailed instructions and troubleshooting regarding the issue?

    Currently, when I am trying to find how to use ODF scan (with Scrivener), I have to search for scattered information throughout the forum. perhaps such a page exist and I missed it, so if this is the case I apologize.

  • Sorry, probably not. We provide usage instructions at and we'll help troubleshoot issues as they come up here, but we don't have the capacity to run a whole troubleshooting knowledge base for a small add-on.
  • I am really surprised I'd be the only one having this problem repeatedly and on multiple (newly installed) systems. So I 've just installed it with debugging on - report D137578991.

    Here are also some screenshots: 

    I'm not saying I have the same problem as the other person. But I AM 'stuck'. Is there realluy no way for me to sideload that file manually? Thanks

  • edited January 19, 2020
    So there are two issues here. One is Scannable Cite no installing with the add-on. That shouldn't happen, but has occasionally been happening before and can typically be fixed easily by manually adding the translator.

    The surprising thing, that we've only had two people mention, and can't replicate, is scannable cite disappearing after it is manually moved to the translator folder (which would be the way to sideload, so to speak, the translator). You're saying that, too, happens to you on multiple computers?

  • edited January 19, 2020
    Indeed. I just sent you two screen capture videos that show both problems 'live'.
  • Problem solved! :) Thanks to 'adamsmith'... So what I had done wrong was to rightclick the Scannable Cite.js file from the JurisM github repo and save it. That one ended up being 103kb. Instead I just had to save the actual raw script, which ended up being 3kb. And that one was accepted right away as soon as I put it in the translators folder. I hope others will not repeat my stupid mistake after seeing this...
  • edited January 28, 2020
    adamsmith, the link you referred to - - provides instructions for regular installation.

    It didn't work for me and I am trying manual installation. I understand I should copy the code from here: ( Cite.js). What should be the next step? thanks.
  • No, don't copy the code. Simply right-click on this link: Cite.js (right-here in the forum) and save the downloaded file into the translator folder in the Zotero data directory. Restart Zotero and Scannable Cite shoudl be available.
  • Yes. So you have to save the raw code (from the URL that Sebastian posted) and NOT from the one you get when you go the Juris-M translators list. That's the mistake I made, and you may have made too, as the earlier link here in the thread was to that one. The size should be 3k and not 131k.
    Incidentally - I can re-confirm that the installation still does not work automatically when one installs odf scan... So we have a functioning work-around now, but it seems to me it would still be preferable if people could have this installed automatically - the way it used to work.
  • I have the same issue.

    Scannable Cite not available despite the extension "ODF Scan for Zotero" being installed.

    macOS 10.14.6
    Zotero: 5.0.83-beta.6+eec0f0078
    ODF Scan for Zotero: 2.0.43

    I checked $ZOTERO_DATA/translators for the file "Scannable Cite.js" and it's not there.

    I confirm that adamsmith's workaround (saving above linked file into translators folder and restarting Zotero) makes "Scannable Cite" available both in the QuickCopy Export drop-down and in the right-click export menu.
  • I just want to report that I experienced the same issue and that the workaround proposed here seems to have solved the issue for me. It is nonetheless strange that a function that I had been using for several years has stopped working.
  • The solution proposed by adamsmith solved my problem, also. Thanks, adamsmith!
  • hi, I am macOS catalina user, and I am using recent version of zotero with scrivener. I was able use scannable cite.js file earlier version of zotero with no problem and citing in scrivener. but currently I agree with other user that this file disappears. I obtained the file weblik that you have provided in this forum and used its content with other file duplication where I deleted the content and paste in another .js file immediately recognized by zotero and shown in the list but this time problem was I could not cmd+shift+C gives error. odd or rtf/odf scan plugin is also problematic, especially libre office even the version 7 constantly giving error about jre environment or not integrating as supposed to be. Even the zotero buttons to oappear you have to manually .oxt file has to be installed but still even if you do it does not cooperates at all with zotero. as a result there is a chain of problems I believe. I am not very knowledgeable on this issues but seems problems reported here I guess valid issues
  • Sorry, this is a bit hard to parse. Here's where we are:

    1. The ScannableCite.js translator doesn't currently install when you install the add-on. That's a known issue.

    2. Manually installing the translator by downloading the .js file and placing it in the translator folder definitely works. If it doesn't, we'd want a more precise, step-by-step description of what you're doing and seeing,

    3. Any issues with LibreOffice have nothing to do with ODF Scan. JRE/LibreOffice has been buggy for a while, on Mac in particular, so this is most likely not even a Zotero issue, but in any case you'd want to report that separately.
  • MacOS Big Sur problem not displaying the "Scannable cite" option in the list of "Default Output Format" for Quick Copy after installing the RTF/ODF Scan plugin.

    The problem was solved by downloading ScannableCite.js, as suggested in the post by adamsmith on January 28, 2020. Thank you!!!

    The downside: An extra 40 min work to figure out the solution.
  • adamsmith's solution of January 28 worked for me too. Live long and prosper, adamsmith!
  • Just to add to the mystery a bit. This is on Big Sur MacOSX 11.2.2 I have just added the ODF plugin to my Zotero install. It shows up in the tools menu as an option. But the Scannable cite is not an option in the preferences when I go to change the quick copy option.

    I downloaded the Scannable Cite.js and manually add it to the translators. Watching the finder window as Zotero starts up and the file is removed during Zotero start up. If I set permissions on Scannable Cite.js to locked, Zotero throws a translator error on start up. I also have Better BibTex installed in case that is an issue. I have removed and reinstalled the ODF plugin as well as a test. I also disabled Better BibTex and still see the behavior.
  • Hello, same case as mansonp here:

    On Mac 10.11.6 I had the ScannableCite.js absence issue and went through the manual installation of the .js document in Zotero/translators/ but it disapeared every time I opened Zotero.

    I hope a solution will be found as this function will allow me to use Zotero with Scrivener, but anywhay thank you adamsmith for your commitment.
  • If ScannableCite.js disappears, you have the wrong file, likely saving the whole webpage rather than the file using the "Raw" link
  • Help would be appreciated but I'm not holding my breath...

    Very peculiar situation here: the sideload of Scannable Cite does not cause it to appear in the Export Format list even though a) I definitely sideloaded the js file (not something else; I have inspected the contents) b) it does not disappear c) ODF Scan for Zotero is installed d) Libre Office is installed.

    NB Other things tried to no effect: set inrepository to false (because AFAICT it isn't in the repository); invoke Prefs... Export dialog... default format dropdown with and without Writer running.

    Q: do I need to close all browsers with connectors, reboot the PC (I don't see anything relevant in the registry, which might be a reason to reboot), other? I haven't been able to do all possible mitigations yet :(

    Apologies if this is not the way things are done here but here's an info dump on the setup (Win 10, 64-bit, 20H2; Zotero

    LibreOffice installed and working (incl. Writer)

    Addons: Better BibTex for Zotero, ODF Scan for Zotero, Zotero LibreOffice Integration, Zotero Word for Windows Integration

    Translators with Export capability...

    "Label" below means the "label" value in the JSON of the js file.

    Of the listed js files, the following don't appear in the Zotero dialog by filename or label: Scannable Cite, Zotero RDF, Wikidata QuickStatements - so non-appearance is not limited to Scannable Cite

    Of the listed js files, the following appear according to the "label" in the JSON of the js file: Evernote (Simple Evernote Export), ReferBibIX (Refer/BibIX)

    In Zotero dialog but not in Translators: Better BibLaTeX, Better BibTeX, Better BibTeX Quick Copy: \cite{citation keys}, Better CSL JSON, Better CSL YAML, BetterBibTeX JSON, Citation Graph

    Note that in order to test the loading/naming mechanism I edited the label of TEI.js, but it remains just "TEI" in the dialog box despite restarting Zotero and noting that the drop-down briefly says "loading" before listing, so it is doing something on 1st use.

    C:\Users\Julian\Zotero\translators\BibLaTeX.js 25 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:15 02/07/2021 08:18:02 1
    3 "translatorType": 2,

    C:\Users\Julian\Zotero\translators\Bibliontology RDF.js 46 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:15 02/07/2021 08:18:02 1
    17 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\BibTeX.js 152 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:15 02/07/2021 08:17:55 1
    20 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\Bookmarks.js 11 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:15 02/07/2021 08:33:24 1
    10 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\COinS.js 9 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:15 02/07/2021 08:33:24 1
    10 "translatorType": 6,

    C:\Users\Julian\Zotero\translators\CSL JSON.js 5 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:15 02/07/2021 08:33:24 1
    13 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\CSV.js 7 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:15 02/07/2021 08:33:24 1
    14 "translatorType": 2,

    C:\Users\Julian\Zotero\translators\Endnote XML.js 54 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:16 02/07/2021 08:33:24 1
    18 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\Evernote.js 3 KB JavaScript File 03/02/2018 06:18:57 03/02/2018 13:59:16 02/07/2021 08:33:24 1
    13 "translatorType": 2,

    C:\Users\Julian\Zotero\translators\MODS.js 117 KB JavaScript File 03/02/2018 06:18:58 03/02/2018 13:59:18 02/07/2021 08:33:25 1
    16 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\ReferBibIX.js 9 KB JavaScript File 03/02/2018 06:18:58 03/02/2018 13:59:18 02/07/2021 07:58:13 1
    13 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\RefWorks Tagged.js 43 KB JavaScript File 03/02/2018 06:18:58 03/02/2018 13:59:19 02/07/2021 07:59:26 1
    15 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\RIS.js 221 KB JavaScript File 03/02/2018 06:18:58 03/02/2018 13:59:19 02/07/2021 07:59:29 1
    19 "translatorType": 3,

    C:\Users\Julian\Zotero\translators\Scannable Cite.js 3 KB JavaScript File 02/07/2021 08:15:53 30/06/2021 10:49:17 02/07/2021 08:15:53 1
    3 "translatorType": 2,

    C:\Users\Julian\Zotero\translators\TEI.js 20 KB JavaScript File 01/07/2021 17:11:22 03/02/2018 13:59:19 02/07/2021 08:15:26 1
    3 "translatorType": 2,

    C:\Users\Julian\Zotero\translators\Unqualified Dublin Core RDF.js 4 KB JavaScript File 03/02/2018 06:18:58 03/02/2018 13:59:19 02/07/2021 08:33:25 1
    3 "translatorType": 2,

    C:\Users\Julian\Zotero\translators\Wikipedia Citation Templates.js 11 KB JavaScript File 03/02/2018 06:18:58 03/02/2018 13:59:20 02/07/2021 08:33:25 1
    3 "translatorType": 2,

    C:\Users\Julian\Zotero\translators\Zotero RDF.js 22 KB JavaScript File 03/02/2018 06:18:58 03/02/2018 13:59:20 02/07/2021 08:33:25 1
    3 "translatorType": 2,

  • I have resolved my problem: entirely due to having Zotero in two places :( Scannable Cite is now available... once side loaded into the correct place.
Sign In or Register to comment.