Connector in Firefox disabled Report ID 561591600

Firefox version 71.0 (64-bit).
Earlier today the connector worked. Suddenly its icon had turned to the grey Z when I tried to store this web page:
Restarted the browser. No cure. Restarted Zotero. No cure. Then restarted Firefox once again. No cure.
Installed updates to Windows 10 (which I have temporarily paused)
Restarted Zotero and then Firefox. Same issue with the web page. Switched to other web pages. Same issue.
Opened Chrome. Here it worked and I saved the page to Zotero.
Uninstalled and reinstalled the connector in Firefox. Then the Web page icon for the connector reappeared instead of the grey Z icon. Pressed F5 to update the page. The grey Z icon reappeared.
In Zotero:Edit>Preferences>Advanced>Files and Folders>Reset Translators...>OK
No cure.
Thanks in advance for help on this issue.
It is not urgent as I can use Chrome. Just very annoying. Maybe a hint that I should stop collecting more information and instead get some writing done.
    Zotero Connector Server is Available
  • Did you install any extensions into Firefox recently? Does it work in a new Firefox profile?
  • Have not installed any extensions recently.
    Created a new Firefox profile. Installed connector. After pressing F5 to update browser window the Zotero icon changes to the grey Z. (aka: same behaviour as before)
  • Have tried to disable all extensions except Zotero Connector. Restarted Firefox. No cure.
    Then also disabled Zotero Connector. Restarted Firefox. Enabled Zotero Conector. Restarted Firefox. No cure.
  • Can you access the connector preferences page? Can you submit a Report ID there?
  • Hope I understood the task correct. Otherwise let me know. I did:
    Extensions>Manage your Extensions>pressed the three dots for Zotero Connector>Options>Advanced>Submit Report
    this returns:
    An error occurred submitting your error report.
    Could not establish connection. Receiving end does not exist.
    Please check your internet connection. If the problem persists, please post a message to the Zotero Forums (
  • edited December 20, 2019
    Yeah, so that suggests that the Zotero Connector isn't able to connect anywhere. That would really be a Firefox problem — Zotero is just a standard browser extension, and it should obviously be able to make network requests using the browser's network connection. If network requests don't work (i.e., you can't even submit an error report) even in a new Firefox profile, I don't really have much to suggest.
  • edited December 22, 2019
    Sorry! Apart from what I did to reply to adomasvens first comment I have been working in Firefox default profile.

    Now I tried to use a new profile. From here I can submit the error report:
    [JavaScript Error: "Could not establish connection. Receiving end does not exist.
    " {file: "[object Object]"}]

    [JavaScript Error: "Frame not found, or missing host permission" {file: "undefined"}]
    After submitting this returns:
    "Your error report has been submitted.

    Report ID: 2020468290

    Please post a message to the Zotero Forums ( with this Report ID, a description of the problem, and any steps necessary to reproduce it.

    Error reports are not reviewed unless referred to in the forums.
    A) I have NOTsubmitted the report ID: 2020468290. Do You recommend that I do that?

    But it does not end here. After installing the Zotero connector anew in the new Firefox profile the Z does not turn grey again. Opening the link mentioned when opening the present report id now shows the newspaper article icon for Zotero. And when pressing this it adds an entry to Zotoro just as intended.

    I have disabled all add ons in Firefox default profile and removed the Zotero add on. Then installed the Zotero connector add once again. But in Firefox' default profile the connector still shows the grey Z and does not work.

    B) Thanks in advance for any suggestions.
  • Thank You.
    I have tried too do that. After installing the Zotero connector again the icon still shows the grey Z. But now I was able to submit an add on error report with report ID: 1487233261. So something seem to have changed.
  • In Firefox, it's expected for the gray Z to appear the first time you install the extension (or in a new/refreshed profile), until you click on it. Does it still not work after that?
  • Jubii. That was the problem. Now the Newspaper icon shows up instead.
    Thank you for your help.
Sign In or Register to comment.