Better BibTeX 5.1.165/5.1.166: "An error has occurred. Please restart Zotero." (fixed in 5.1.167)

edited December 3, 2019
When I load Zotero, I can see all my references, and browse my libraries. However, none of my citation keys are shown. When I click on an item, I immediately get "An error has occurred. Please restart Zotero." -- I have done this multiple times, but I'm always getting the same error.

This has only started happening today -- it was finie

I've taken printscreens, but I don't know how to attach them to this discussion...
  • The Citation Key field is provided by Better BibTeX, so that's a question for @emilianoeheyns.
  • Ok, thanks. I just remembered (and should have earlier): Zotero did update immediately before this happened.
  • Yes, there were changes in 5.0.78 affecting plugin compatibility. BBT was updated, but it looks like there are still some issues.

    For Emiliano, here's the relevant error:
    [JavaScript Error: "Error: Invalid field 'citekey" for base field" {file: "chrome://zotero/content/xpcom/data/itemFields.js" line: 283}]
  • Also reported on the BBT issue tracker.

    Until a BBT update is out, you can avoid the crash by disabling BBT in Tools → Add-ons.
  • Yes I have the exact same issue. Anyone resolve this. Mine updated recently as well.
  • edited December 2, 2019
    @Up919040 I guess we just have to wait for Emiliano. If you look on dstillman's last post, you can see he has commented on there (he's "retorquere"). I'm sure he's got his hands full this morning, and so we just need to be patient :)
  • @smthomas Yeah thanks for that. This helps for now and allows me to continue at least. Cheers.
  • @dstillman your suggestion with BBT works so able to proceed for now. Thanks!!!
  • Same problem here. Disabling BBT addon solved the problem, only it caused Zotero to reset column view preferences with all the columns selected, included the extra ones (had to manually uncheck one by one).
  • also broken for me see report 1970369385 . The experimental build of BBT test build does not fix the issue for me. This is a major bummer and I kindly suggest to test compatibility with such a major plugin before an unattended upgrade of Zotero :(
  • @tobias_kramer: Zotero 5.0.78 was in beta for months, BBT was updated for compatibility a while back, and there've been no reported problems with BBT and the beta. (It's not clear that the Zotero version even matters here, since someone apparently reproduced it with 5.0.77.)
  • well, then this occurrence might be a good chance to review and improve the testing, since it didn't catch this case. I am willing to pay for Zotero (and do), since I rely on it for work, and I am certainly grateful for all efforts. Please see this case as a chance to improve the workflow, it is highly appreciated. Thunderbird delayed the unattended upgrade with the last major revision for several months to iron out major bugs, maybe something similar should be considered for Zotero?
  • Any testing changes would be on the BBT side. This isn't a Zotero issue.
  • Maybe then a chance to improve relations with BBT. Or to integrate BBT closer with Zotero, since so many people are using this plugin, it obviously adds value to Zotero and makes it more useful for us users.
  • I don't have any problems with Zotero 5.0.78 and BBT 5.1.164. The problem seems to be with BBT 5.1.165 and higher. Thanks for the announcement. I could disable BBT auto-update in time.
  • A fix for BBT is out. Sorry for the mayhem people.
  • Thanks @emilianoeheyns! It didn't pick up the update itself straight away, so I just went onto Add Ons, right-click and "Find Updates". All good now, thanks for sorting it so quickly! :)
  • Thanks for rapid work @emilianoeheyns -- really appreciate. All seems to be working for me now.
  • Appreciate it, but I feel pretty shitty about this having slipped through. It's absolutely nothing Zotero could have anticipated or prevented. This one is squarely on me. I run tests on zotero release and beta every night, but because this bug was caused by the parts that facilitate testing in BBT it slipped through the cracks, as in test mode, it would not show. Bleh. Again, sorry people.

    @dstillman is it possible to amend the announcement subject so that it's clear BBT needs to be updated? The broken versions have been removed, so no new installs can happen, but if people have 165 or 166 installed but not restarted,it is possible that they're actually still running 164 until restart.The zotero upgrade would restart zotero,and boom. That's my hypothesis anyway for this coinciding with the zotero upgrade.if this is the case,and you upgrade bbt before restarting,the problem won't occur.
  • I've updated the subject.
  • edited December 3, 2019
    EDIT: Never mind, apparently it just needed time and a few restarts. It's all working now :D

    Is it possible that another bug has crept into 168? My cite keys won't load either and when I quit zotero, it gives me an error message:
    "Zotero was unable to load translators and styles."
    I've tried resetting as suggested, but to no avail.
    My PhD is due in 10 days and I'm freaking out!
  • @bjtho08: @emilianoeheyns will want some BBT debugging info, but for our side, can you provide a Report ID?
  • Come on over to github and I'll figure it out.
  • (it's always possible a bug crept into 168, but it would be an older bug. 168 was a really targeted fix, hardly anything changed)
  • (indeed I'll need BBT debugging info as I rightly can't read Zotero error reports)
  • edited December 3, 2019
    phew. Not sure why multiple restarts would help anything, but I'll take what I can get. Off to go find my hair shirt.
  • I think this can be un-stickied now. People should have been automatically upgraded by now.
Sign In or Register to comment.