Zotero cannot access my login information

Report ID: 1260936067

Zotero displays an error message when I start the application, which goes

"Zotero cannot access your login information, possibly due to a corrupted Zotero logins database.

Close Zotero, remove cert8.db, key3.db, and logins.json from your Zotero profile directory, and re-enter your Zotero login information in the Sync pane of the Zotero preferences."

I've tried looking for these files via profile directory (https://www.zotero.org/support/kb/profile_directory), but they seem not to be there.

I've also tried to cancel the error window displayed and login via Set Up Syncing button and when I type my login details, I get another error, which goes

"Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"

Also need to metion, that I'm a new member of Zotero and I've never managed to login. I've even tried to:
- delete my profile (username: n0889549) and create a new one;
- uninstall the app and install again;
- delete Chrome extension and install again.

and nothing worked.

Hope we'll find the answer. Thank you in advance!
  • edited October 6, 2019
    I've tried looking for these files via profile directory (https://www.zotero.org/support/kb/profile_directory), but they seem not to be there.
    What are some of the other files you see in the directory? There's a good chance you're looking in the wrong place.
  • There's only one folder in Profiles folder, named "8h0m4uwv.default". It contains "crashes" and "gmp" folders and some files, such as "cookies.sqlite", "extensions.sqlite", "permissions.sqlite" etc.
  • And you don't see any of those three files in this folder? If you sort the folder by modification time, do you see other recent files? What are some filenames? Could you take a screenshot, upload it somewhere (e.g., Dropbox), and provide a link here?

    But basically, if those files aren't being created, something on your system — likely security software — is interfering with Zotero's normal operations. You can try temporarily disabling your security software to see if that helps.
  • I am not using any security software.

    Here's what I see in the folders "8h0m4uwv.default" and "crashes" (all the other folders are empty):
  • I would try closing Zotero and deleting the Roaming/Zotero directory altogether. Something on your system — security software, malware, some sort of institutional restriction, permissions in that directory that somehow became incorrect — is preventing Zotero from creating those files. We haven't had any other reports of this, and I'm afraid I don't really have anything else to suggest.
Sign In or Register to comment.