OSCOLA & LibreOffice: cross-references (n ...) suddenly not respecting per chapter numbering

I have been using (regular, not MLZ) Zotero together with LibreOffice for years now, almost exclusively using the official OSCOLA style. I am currently in the process of preparing my PhD thesis for publication with a major publisher. The entire thesis is in one .odt file.

Up until this point, the OSCOLA style has automatically handled cross-referencing with subsequent references (n ...), even though I restart the footnote numbering on a per chapter basis. It has just worked beautifully - until I today clicked the "refresh button" after adding some references. Now it appears that the cross-references are not respecting the per-chapter numbering, but instead refers as if there was a continuous numbering throughout the manuscript.

It is a while since I last did edits to the manuscript, so I am not exactly sure what has changed since the last time it worked. All I know is that it certainly did work in December 2018, when I submitted the manuscript for review. I see that the style was updated in January -- perhaps an error was introduced then?

Any help would be greatly appreciated. I have a deadline in less than 14 days, and would definitively prefer not to renumber all my subsequent footnotes by hand...
  • After a closer look at the edits made to the OSCOLA style in January, it seems unlikely that it is the culprit. But I see that the Zotero LibreOffice plugin has had extensive edits over the summer that concern footnote numbering: https://github.com/zotero/zotero-libreoffice-integration/commits/master

    Perhaps @adomasven can help out?
  • Numbering of footnotes is controlled by LibreOffice. All Zotero does is tell LibreOffice “Insert a footnote/endnote here.” And Zotero doesn’t have a cross-referencing feature at all. That’s a LibreOffice feature. So this would be a LibreOffice issue not a Zotero issue. Do you get the same problem in a new empty document with sections/chapters and just a few citations?
  • Oby
    edited October 2, 2019
    Yes, I see the same issue with a new document, where I insert just a few citations as a test:

    - Full citations are not given when a reference is first cited in a new chapter.
    - Cross-references (n ...) are given as if footnote numbering (or "counting" as it is called in the LibreOffice footnote settings) are set to "per document".

    Both of these things worked before, over several years, as described above.

    PS: While Zotero does not have a cross-reference feature as such, the OSCOLA style has some way of actually doing them. I guess there is an advanced macro of some sort. It has worked beautifully for years. But my uneducated guess is that changes in the LibreOffice plugin has either introduced a bug or created a need to amend the relevant OSCOLA style macro.
  • How exactly are you separating “chapters” in LibreOffice?
  • Oby
    edited October 2, 2019
    Using the "Heading 1" style for each new chapter, in combination with the "per chapter" option for footnote numbering in LibreOffice.
  • (I think there is a misunderstanding about "cross-reference" here -- Zotero does have "first-reference-note-number", which does allow it to automatically reference the note an item was first cited in. It just doesn't have the ability to insert what's called a cross-reference in Word/LibreOffice, i.e. actual links within the document.)

    @Oby, and you're absolutely positive this worked previously? I've never tested on LO, but the fact that Zotero's references to previous footnote numbers always count as if footnotes start at 1 has been a long-known issue going many years back with multiple threads on the forum and devs have long said that there is no way they can retrieve the "actual" footnote number from the word processor. It could be that all of those referred to Word, but I'm puzzled that this would ever have worked.

  • Oby
    edited October 2, 2019
    Thanks for clearing up my use of the term "cross-reference".

    Yes, I am indeed certain that this did work in LO. I see from a lot of forum post that this is not the case in Word. But, as I wrote above, I have been using this functionality continuously while writing my thesis (2013-2017) and when revising it for submission to publishers (in 2018). I even have versions of the documents with correct "first-reference-note-numbers" as backups.

    Only now, in september 2019, do I see a different result. When the change occured between december 2018 and september 2019 I am unsure of. Perhaps I should try to downgrade my Libreoffice Zotero integration extension and test?
    I managed to install version 5.0.14 of the LibreOffice integration, and it works as I describe. In other words, I have now isolated the issue to the LibreOffice extension changes since then.

    Here is a very simple document with referenced updated using 5.0.14: https://www.dropbox.com/s/4000kphqyi4ou2h/Zotero_test.odt?dl=0
    (Pay particular attention to the citation of the book by Crawford, which is cited in both chapters.)
  • Further testing reveals that the expected output (correct "first-reference-note-number" per chapter and full references upon the start of each chapter) works up to and including version 5.0.18.

    From version 5.0.19 I get a different output, see this example (generated with version 5.0.19): https://www.dropbox.com/s/5wvl0n15027twqb/Zotero_test_2.odt?dl=0

    Since I was now able to isolate when this changed, I was also able to identify the relevant commit: https://github.com/zotero/zotero-libreoffice-integration/commit/bb21e3c150994254d41003c39a5a0a5ba9ca2188
    Lo and behold, this is actually mentioned in the comments on the commit by @fbennett

    Apparently, this is a known consequence and the regression is argued to be acceptable since it "this just brings LibreOffice inline with what Word produces anyway". I don't really see that it is a particularly good argument per se, but I see that there are also technical arguments for the change that I am not qualified to evaluate.

    At least I will be able to do what I need for this document by using version 5.0.18 when updating the footnotes a final time. Hopefully, it will be a long time before I embark on a monograph again. I hope by that time that Zotero is able to do per chapter footnotes.
Sign In or Register to comment.