Zotero crashes on startup - memory issue (?)

Since a couple of days, Zotero has stopped working, crashing before completing initialization. It seems the problem is javascript-related lack of memory, but Task Manager tells me Zotero never goes above using c. 40% of memory while loading.

This same problem has happened before a few times. When it did, I just cleaned up the computer using CCleaner and this solved the problem. A few times when this didn't work, reinstalling Javascript did. Neither strategy worked this time.

I should add that my library is very large. Precisely because Zotero isn't loading succesfully anymore I can't check exactly how large it is now, but it has surely over 200,000 entries. Because of the size, loading Zotero usually takes 40 minutes to an hour. Now, with this problem, Zotero still takes up all this time, but then shows the error message.

Error ID is 1079156139.
Debug ID is D125402979.

I would appreciate any help to get things back to work again. And any tips to streamline Zotero usage with very large libraries.

Thanks.
  • Hello, I tried today again on another computer, just in case. Still didn't work, same problem. But this time I also got a message that "translators not yet loaded", which hadn't happened before, together with the javascript memory problem mentioned above.

    Here are the newer references:
    Error ID 1980730654
    Debug ID is D1815557252.

    Please help. Thanks.
  • Also, since I can't give you a more exact estimate of the total size of my library (which I guess is northwards of 200,000), I checked the "storage" folder, and therein are 100,545 subfolders. Total size should be around 1.2 TB. The zotero.sqlite file is 2.4 GB in size. Don't know if this helps. Thanks.
  • Zotero on Windows is still 32-bit, so the system limits it to ~3 GB of RAM. While it obviously isn't ideal that it's taking anywhere close to that amount, in an extremely large library it could happen under the current design.

    We're working on offering a 64-bit version of Zotero for Windows, which would likely help with this. If we're able to do that, it will hopefully be available within the next few weeks.

    In the meantime, I'm afraid your best bet, if restarting your computer and leaving other apps closed doesn't help, would be to open your library on macOS or Linux where it can use more memory.
    A few times when this didn't work, reinstalling Javascript did.
    (Note that this isn't a thing. You're thinking of Java, not JavaScript, but that also wouldn't affect Zotero.)
  • Thank you very much, dstillman.

    If I understand correctly, there's nothing to do but wait until this new 64-bit version of Zotero is made available.

    Please let the "next few weeks" be very few!

    Thank you again to the developers for making Zotero the great tool it is.
Sign In or Register to comment.