Zotero Extension Not Showing in Google Docs

Report ID: 826012574

The Zotero extension is not showing in Google Docs.

Steps to Reproduce:
1) Open Google Docs
2) Look for the Zotero Extension in the toolbar
  • That's a Report ID from Zotero. The issue here would be the Zotero Connector in your browser.

    Try uninstalling it and reinstalling the connector, make sure Google Docs support is enabled in the Advanced pane of the connector preferences, and provide a Report ID from the connector if you're still not seeing a "Zotero" menu in Google Docs.
  • I'm seeing the same problem, with both the Zotero Connector for Firefox and for Chrome. Happened during a Zotero instruction session, to my chagrin!

    I've submitted Report Id: 712873792 (Zotero Connector for Firefox)
  • Could you take the screenshot of the full Google Docs page, upload it somewhere and post a link here? Also, is the chekbox for Google Docs checked under the Connector preferences and is the Zotero menu not appearing in new documents too?
  • Thank you, and sure! I've uploaded screenshots of both the Connector preferences and the full Google Docs page to https://drive.google.com/drive/folders/1YIldt1MksA3-7wKDf07bG8xdEOWti__r?usp=sharing

    The Zotero Connector preferences checkbox is checked.

    The Zotero menu is not appearing in new documents; I had created a new Google Doc during the instruction session this morning, and that's when I noticed the Zotero menu was missing.

    Also, I did uninstall and reinstall the Zotero Connector before submitting the Report ID.
  • Added note: I found that with the Zotero Connector for Chrome, clearing the "Google Docs" Connector preference and then checking it again seems to have re-enabled the Zotero menu in Google Docs.

    However, following the same procedure with the Connector for Firefox does not resolve the problem.
  • Added note: I booted into Linux (the OS I use outside of instruction sessions) and in both Chrome and Firefox the Zotero menu *is* present in the same Google Docs documents.

    So right now the problem--for me at least--appears to be limited to Firefox on Windows 10.

    The problem _was_ initially present for me on both Chrome and Firefox on Windows 10. The variability is the worrisome part; we can't expect normal users to uninstall/reinstall the Zotero Connector or go into the Zotero Connector preferences to clear and then re-check the Google Docs integration checkbox. They need to be able to count on the Zotero menu being there every time.
  • edited October 4, 2019
    I see you have a lot of other extensions in Chrome, do you have a lot of extensions in Firefox too? Have you tried disabling them?
    The variability is the worrisome part; we can't expect normal users to uninstall/reinstall the Zotero Connector or go into the Zotero Connector preferences to clear and then re-check the Google Docs integration checkbox. They need to be able to count on the Zotero menu being there every time.
    This is not normal behaviour. We have occasional reports of people not seeing the menu, but it usually means something else is interfering with the display of it. I asked for screenshots since we have had a small increase of these reports recently and I was wondering whether some users are being served a different version of Google Docs editor, although it does not seem that way from your screenshot.
  • Haven't had time to reboot into Windows on this machine until now. Of course, the Zotero menu now shows up in the Google Docs menu in Firefox and Chrome, with all of the same browser add-ons still in place and enabled.

    Google's widespread A/B testing makes your theory possible. Or maybe it's a race condition? Unfortunately I guess we're no further ahead in sorting out the issue :(
Sign In or Register to comment.