Style Request: Journal of Molecular Biology

Hello all...

I'm relatively new to zotero.I am writing a manuscript for JMB. I looked in the list of journal styles and was surprised to not find JMB among the other thousands of journals. Maybe I'm missing something but I would like to use my zotero library for this manuscript and I cant figure out a way to do it. Does anyone know how I can make this work? The format is as follows except the volume is bolded and the journal title is italicized (et al is not used either, complete author list)

43. Sim, R. B. & DiScipio, R. G. (1982). Purification and
structural studies on the complement-system control
protein beta 1H (factor H). Biochem. J. 205, 285–293.

    (main issues - identify similar styles, provide link to style guidelines)
  • The style is similar to Nature (differs only by the position of the year). I changed the Nature style. You can download it from here:

    I'll put it in the repository as soon as I get SVN access.

    The one issue I see is that not all journal names are abbreviated as is required by the instructions to authors. This is a known problem:
  • i am also using the JMB style -- thanks. unfortunately it is still not in the main repository. Also it retains the Nature style tendency to cut the author list to 'Author1 et al.' which is not used in JMB. Perhaps this could be changed as well.
  • I'll have a look as soon as possible:
    Peter - can I add a creative commons license to your style and put it up?
  • ok, I've reached Peter by email and the style is now up in will show up on the repository in the next 30mins. Any problems let me know.
  • hi, the JMB style started to produce disastrous results suddenly -- it refuses to format the references in the text as superscript, just leaves them as plain text. this happened after i tried to use the 'multiple sources' option, it corrupted the citation i was trying to insert first, then the whole manuscript after i pressed the refresh button. now i cannot insert properly formatted references at all. any ideas how to solve this? -- thanks.
  • try switching to a style using footnotes - e.g. Chicago Manual full notes - and back.
  • doesn't work. Chicago converts to superscript ok, but JMB back to standard text again.
  • and another style that uses superscript like Nature?
  • edited February 15, 2013
    I use OpenOffice. These styles, Nature and Chicago work correctly themselves, i.e. references are re-formatted as superscript when I change the settings. But when I change back to the JMB style, the superscript part of the formatting is not working, the numbers remain at the same level as normal text. The JMB style worked correctly, but when I tried to use the multiple sources option it produced this effect, first just for the reference I was inserting. Then gradually this spread to the whole MS, to the references that were already there formatted as superscript, as if some kind of tag have been removed or changed in each reference field. Finally every reference in the MS was changed. Now even if I insert a new reference, it is formatted as normal text. Superscript is not working. I tried to delete the style and install it again from the website, it didn't change anything. I copied small part of the text - without a single reference, from the MS to a test file and tried inserting a reference, didn't produce superscript either. It looks as if there was some kind of corrupted formatting tag in the text that prevents correct formatting. Or a bug in the style. Perhaps the part of the style that produces superscript needs to be checked or simply copied to the JMB from the Nature style? Hope something can be done to remedy this.
  • the in text citations for JMB and Nature are already equivalent in the style code, so that's not the issue.
    Have you tried using JMB in a new document? Sorry I need you to run through these things, but this works without problems for me so we just have to look around until we find something useful.
    Re-installing was a good try. Which Zotero version are you using?
  • They are not fully equivalent though.
    Thanks, I will do all this again tomorrow and post the results and Zotero version. My Firefox is not the latest version, could this cause such error? I have no access to this computer now.
  • Trust me, the sections that produce the in text citations are exactly the same. See for yourself:
    Lines 71-78 in JMB and 84-91 in Nature.

    It's always a good idea to work with up to date software to eliminate possible issues, though I doubt that the FF version is the problem here. Also try 2-4 here: If you still remember your multi citation that presumably broke this, delete and re-insert it.
  • Hi, I am using Zotero 3.0.13 , Firefox 12.0
    I have
    1. reinstalled Zotero OpenOffice extension from the Zotero Cite menu, and restarted computer
    2. removed and installed Zotero LibreOffice Integration 3.5.4 extension from Firefox and installed again, restarting Firefox
    3. created new document using OpenOffice 3.1.1, inserted citations, created bibliography
    4. created new document using LibreOffice 3.4.5, inserted citations, created bibliography
    5. in both documents JMB and Nature styles don't work correctly - the citations are not in superscript
    6. Chicago style works correctly, formats as superscript both in footnotes and endnotes
    7. both JMB and Nature used to format citations correctly before, until I tried 'multiple sources' option. now they don't work in documents that are new, and not linked to my MS - no text copied from there or anything, even the citations I quote in the test documents are not used in my MS
    8. not that this is relevant, but it's not clear to me what is 'Check for citations in image captions.' in Debugging broken documents (2)?
  • Do update your software - OOo, LO, and Firefox include multiple bugfixes in their updates and if it turns out that one of those bugs is the reason for your problems, we'll have wasted a lot of time.
    I.e. you should be using Firefox 18.0.2, and, ideally, LibreOffice 3.6x or 4.0, or alternative Apache Open Office 3.4.x

    Then try "reset styles" from the advanced tab of the Zotero preferences and reinstall the JMB style, see if that makes a difference.

    5. Yesterday you said "Nature" worked correctly - was that the case then or did we miscommunicate?

    8. If you insert an Image in Libre Office (or Word) you can right click it and select "Caption" to add a caption. While Zotero won't let you insert a citation into a caption, it is possible to copy an active citation into a caption and that is likely to corrupt the document.
  • Thanks,
    I will see what I can do. I can't update some of the software, I use Red Hat and it would involve updating the whole system as well. I thought Nature worked OK yesterday, but it doesn't today.

    Also, of course up-to-date software is important, but Chiacgo style does work correctly. It produces superscript. Perhaps it is coded more robustly than Nature and JMB? If this is the case why not just use the Chicago code in the two other styles.
  • no, Chicago Style and JMB/Nature are fundamentally different.
    The former inserts footnotes/endnotes (which happen to be arabic numbers in superscript, but whether they are or not depends on the settings in LO/Ooo), the latter insert - or at least try to insert - arabic numbers in superscript, regardless of your word processor's settings.
    You're also the first person to encounter this problem, so this is something quite peculiar to your set-up.
    Then try "reset styles" from the advanced tab of the Zotero preferences and reinstall the JMB style, see if that makes a difference.
    you can try this first, maybe it'll work.
    Another thing to check would be if there is anything unusual about your "Default" formatting style in Ooo/LO (press F11, and right click on "Default" -->modify. You'd likely be most interested in the "Position" tab, but check more generall.
  • I did a Java update today, maybe this is why Nature stopped working. In any case thanks very much for your help, hope this problem can be solved.
  • more of amazing news
    I took a completely different computer, a macbook pro. I have installed on a macbook pro: Firefox 18.0.2 , Zotero 3.0.13 , OpenOffice 3.4.1 , Zotero Libreoffice Integration 3.5.4
    Synced my references. Reset styles, added JMB style
    opened a new document - Chicago creates superscript, Nature and JMB don't. I am impressed ))

    the default formatting style looks fine. what exactly should I look for? what formatting style is used by the JMB references style for the in-text citations, it can't be default?
    could my whole reference database become corrupted somehow?
  • never mind - I can replicate this now.
    I'll see who/how we can fix this and keep you updated here. For the time being I'd just keep inserting citations in any style you want - once this is fixed on the Zotero side it should fix itself for you.
  • if you need this to work immediately, you can revert back to the old version of the LO plugin:
    the main drawback - which doesn't affect you - is that it doesn't work with LO 4.0
  • thanks this worked
  • Can you give the LibreOffice Trunk XPI a try and make sure this is fixed there? You'll need to manually install version 3.5.5 of the LibreOffice plugin when it is released later this week.
Sign In or Register to comment.