Ctrl+Shift+S keyboard shortcut not working in firefox developer edition

I'm a vision impaired screen-reader user, and Zotero team's suggestion to use firefox developer edition worked for me for sometime. With recent updates, firefox by default opens the screenshort option upon pressing the ctrl+shift+S. Nor am I able to find the save buttons described in the documentation page using the keyboard.
I'll even try adding books/articles using ISBN/DOI, only if you could tell me a way to access that option using keyboard.
  • Kindly read "using Keyboard" as "using keyboard shortcuts".
  • There's no need to use the Developer Edition anymore. Extension shortcuts are configurable in current Firefox versions.

    It's likely random whether the Zotero shortcut or the Firefox screenshot shortcut takes precedence, but you can go the Extensions pane in Firefox, click the gear button labeled "Tools for all add-ons", and select Manage Extension Shortcuts from the drop-down menu. From there, you should be able to configure both shortcuts. If you set Firefox Screenshots to something else, you can continue to use Ctrl+Shift+S for the Zotero Connector.
  • Yes, it works perfect now!
    thanks dstillman
Sign In or Register to comment.